Quick Export problem - no features in the selection set

264
6
Jump to solution
04-18-2017 04:38 AM
Highlighted
New Contributor III

I'm having an issue using the Quick Export feature to our enterprise database.  In the past I have used quick export to write point features to our database without any issues.  For this task, I am trying to write out line features to the same database.  The connection is good but I am seeing a strange warning message in the results:

Has anyone seen this message before?  What should I do to correct this?

This particular line feature is created using an OD Cost Matrix using model builder.  Here is the output portion of that model:

If I need to adjust how my model is creating the feature class, I can do that, as my end goal is to export this data correctly to the database. 

The feature class I am trying to export:

Any help would be greatly appreciated!  Thanks!

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Regular Contributor

In the Catalog window of ArcMap open up the toolbox in which you have saved your model and right click.  There will be an option to create a Spatial ETL tool.  The Workbench application will open.  Add a Reader for your lines data (whichever geodatabase type you are using) and add a Writer for Netezza.  It should default to writing the schema from the lines, if not plumb that in.

Creating a spatial ETL tool—Help | ArcGIS Desktop 

View solution in original post

6 Replies
Highlighted
Esri Regular Contributor

Jim, why use Quick Export?  You can use Copy Features or Feature Class to Feature Class.

I have seen the warning you're seeing in Spatial ETL tools and as far as I know it is meaningless.

Reply
0 Kudos
Highlighted
New Contributor III

Hi Bruce, Good question.  Those functions do not work with PDA (Netezza).  They do work just fine going to SQL server but unfortunately I need to send this information over to Netezza.  I'm not really concerned about the warning, but the fact that 0 features were written is the real issue here.  It's weird how this works perfectly with point features but no line features.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Ah I see.  If you are embedding Quick Export in a Model it will try and inherit the GP environment and there may be a bug in this.  Log a support call.  Try adding a selection step in your model (make layer, select by attributes) or create a Spatial ETL tool that takes the output from Select Data and writes to Netezza.

Highlighted
New Contributor III

Thanks.  I will try those items and if nothing works I will call support.  How do I launch into the ETL tool?  I've looked at that in the past but can't remember how to find it.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

In the Catalog window of ArcMap open up the toolbox in which you have saved your model and right click.  There will be an option to create a Spatial ETL tool.  The Workbench application will open.  Add a Reader for your lines data (whichever geodatabase type you are using) and add a Writer for Netezza.  It should default to writing the schema from the lines, if not plumb that in.

Creating a spatial ETL tool—Help | ArcGIS Desktop 

View solution in original post

Highlighted
New Contributor III

The Spatial ETL tool was able to write the data into Netezza without issue.  Thanks a bunch!!!!!!!!