Point Features not fully displaying

1619
4
03-16-2016 01:15 PM
Highlighted
Occasional Contributor II


Hello,

I have a point feature class that was created by geocoding a bunch of addresses out of an excel table.  When these points are added to my map, it appears that only a small portion of them are displaying.  I cannot determine why this is happening.

The point feature class contains 30,539 points.  I have selected a subset of around 25,152 of those 30k points (select by location using the polygon shown).  Yet on my map it is only showing around 20 points as being part of that selection (see attachment).  For some reason ArcMap is not displaying all of the points.

I am wondering if there is some sort of setting turned on that is filtering out the display of all points in order to optimize display rendering or something along these lines?  I have attempted to export this FC as a new FC and get the same result.

Attached is a screenshot. Notice at the bottom where it says 25152 out of 30539 selected, yet in the map view I am only seeing about 15-20 points...(I had to hide some fields in my attribute table)

Your contributions are greatly appreciated. Hopefully this is an easy one to solve for you experts out there. I am using ArcMap Desktop Basic 10.3.1.  Thanks!

Reply
0 Kudos
4 Replies
Highlighted
MVP Esteemed Contributor

This question already has an answer Point Features not fully displaying

In short, there were duplicates because of the geocoding process returning unexpected results.

Reply
0 Kudos
Highlighted
MVP Notable Contributor

Dan, not to be insensitive, but can we remove this thread since the other thread is a duplicate? I would just want to alleviate any confusions, etc.

Reply
0 Kudos
Highlighted
Occasional Contributor II

Why is geonet creating duplicate threads when we ask questions?  It wasnt like this before from what I can remember. Is this some sort of new interface?  This is the second time I have seen this happen now with questions I have asked.

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

There have been a few hiccups apparently... Tyler can delete the thread... I think... I just cross-referenced so that we didn't get two streams of answers...it is bad enough when someone also posts on Stack Exchange as well

Reply
0 Kudos