ORA-20085: Insert Spatial Reference SRID does not match

3994
6
05-08-2012 03:41 PM
RobertMartin2
Occasional Contributor II
I am trying to compress a versioned Oracle-driven geodatabase. When I run the Compress Database command in ArcCatalog I get the error:

Failed to compress the database.
Underlying DBMS error [ORA-29875: failed in the execution of the ODCIINDEXINSERT routine
ORA-20085: Insert Spatial Reference SRID 10 does not match WAT.WHYDRANT.SHAPE registered Spatial Reference SRID 8
ORA-06512: at "SDE.ST_DOMAIN_METHODS", line 1913
][SDE_WAT.DEFAULT]


After doing some research it seems like this is a spatial indexing problem, but I'm not sure exactly what. Can anyone help shed some light on this?


Thanks in advance,

Robert Martin
0 Kudos
6 Replies
AlisonGaiser
Occasional Contributor
Robert,

Did you manage to fix this issue? I have run into it a couple of times now. The way I fixed it the first time was by deleting the feature class and recreating it.  Now that it has happened a second time, I would prefer to find a solution.

Any suggestions are appreciated.

Thanks,
   Alison
0 Kudos
Leandro-Zamudio
Occasional Contributor
I have the same problem when i try to compress my geodatabase SDE.

Anyone has te same problem or a solution.

Greetings
0 Kudos
anilkumar
New Contributor II
I am having the same problem. I am replacing the featureclasses for time being. Please help me if anybody know the solution.
0 Kudos
anilkumar
New Contributor II
I exec'd this command 'UPDATE xxxxfetureclassXX SET shape = sde.st_transform(shape,5);

Result:

Error starting at line 1 in command:
UPDATE xxxxfetureclassXX SET shape = sde.st_transform(shape,5)
Error report:
SQL Error: ORA-28595: Extproc agent : Invalid DLL Path
ORA-06512: at "SDE.ST_GEOMETRY_SHAPELIB_PKG", line 788
ORA-06512: at "SDE.ST_GEOMETRY_OPERATORS", line 2577
28595. 00000 -  "Extproc agent : Invalid DLL Path"
*Cause:    The path of DLL supplied for the extproc execution is invalid.
*Action:   Check if the DLL path is set properly using the EXTPROC_DLLS
           environment variable.
0 Kudos
AnjithaSenarath
New Contributor II
Does this help:

http://support.esri.com/es/knowledgebase/techarticles/detail/42335


This happen due to indexes. When we try to insert or update a feature from different projection Oracle return error
0 Kudos
NidhinKarthikeyan
Regular Contributor II
NIM099594. Fixed in 10.3.
0 Kudos