Missing data after raster clip

1773
3
04-01-2011 12:09 PM
judyrondeau
New Contributor
I am using vector data (polygons) to clip land cover image files (ct_2006lc_v2.02), using the data management < raster < clip tool. The problem I am having is that after the clip is complete, the attribute table shows no counts associated with the various land cover values, so I essentially have an empty image. Has anyone encountered this problem, and is there a fix?

Thanks!

Judy
3 Replies
RachelSmith
New Contributor
I am having the same problem.  I've tried clipping the raster to different formats, different compression options, etc... and still the same problem.  Not only does it create an empty raster, but the min/max values change.  They should be roughly 900 to 7500 and after the clip the min/max numbers become very large negative to very large positive numbers.  (I've already deleted some of my attempts or I would state the actual numbers.) 

I would love to get some feedback on how to fix this problem.  I've also tried using the image analysis window in ArcMap to perform the clip and I get the same results.

My input data is a DEM that is very large and I've tried clipping with a shapefile and with a feature class in a geodatabase. 

Please help!
0 Kudos
larryzhang1
New Contributor III
It should work, but too slow! Please make sure your workstation has latest service pack installed (ArcGIS 10 SP2 or 9.3.x SP2). If still failed, try it again in other workstations.

Wth ESRI solutions, you also can try Mosaic Dataset with �??Clip function�?? in the function chain.  Personally, it is an effective approach, but still is not efficient to get different imagery formats with specific compressions done, i.e., hard or too slow to export.

Actually, for majority of raster operations, in practice, the efficient way is to use other imagery/GIS software like ERDAS Imagine or FME (Safe), in particular, when working with large batch of operations like clipping & exporting on predefined shapefile or AOI file.

For more on FME, link at http://cdn.safe.com/resources/fme/FME-Transformer-Reference-Guide.pdf
0 Kudos
CliveCartwright
Occasional Contributor
Yep, I've also been getting the same problem using ArcGIS 10.0 and I'm sure i'm using the latest service pack.
My experience is clipping a few thousand polygons with about 10 fields of attribute data with a simple rectangle polygon. After the clip, all the fields show one value... It's as if the software can't handle large datasets.

I've tried it on other workstations but it still happens. I'm at home now, but when I return to work, I'll double check that I have the latest service pack.
0 Kudos