Invalid raster dataset. Failed to create raster layer

07-21-2011 09:45 AM
New Contributor

I encountered this error after installing v10 on a windows 7 machine. I tried to add a DEM in ArcMap and received the following error:

Invalid raster dataset. Failed to create raster layer.

The same files open up fine on my other machine running XP and v10. Has anyone else had this problem? If so is there a solution?


0 Kudos
4 Replies
New Contributor
I am getting this very same error message when trying to open up a DEM image...

And when I try to sort out its properties in ArcCatalogue I get an error message that reads: Failed to Open Dataset

Does anyone have a solution for this?  Or is this all indicative of the a corrupt file?

Just installed ArcGIS onto the Windows portion of my Mac.  I access the program via VMWaren Fusion.  Not sure that this is causing a problem?
0 Kudos
New Contributor
We're having the same problem. Our office just "upgraded" to windows 7 and we can no longer load DEM's. Anyone?
0 Kudos
Regular Contributor
Transterritorial -
The mac portion may be the problem depending on the path and also whether that drive can be accessible from the MAC side as well. The most stable version of ArcGIS on MAC is still when it is loaded via Bootcamp.

I think that for the rest, if these DEMs are Esri GRIDs you should consider the path to the raster.  I have seen issues with spaces, leading number file names and special characters.  If the path to your raster contains these, then I would recommend changing the path or moving the rasters.  In terms of spaces in the path, I have seen issues on certain systems and not other systems on the same network.  Personally, I have added up to 14 spaces in the folder path for my test machine and not had an issue.  However, I have also see a space being the cause of a problem for a user.  So consider the path wisely. If you are still having issues, then I recommend opening a Support Incident and we can take a look at what may be causing the issue.
0 Kudos
New Contributor
Hi there!
Let me tell you my story about this issue. I read many and many threads and advices but nothing helped me. I take the message "invalid raster dataset. failed to create raster layer" probably a million times. I've reinstalled my OS and changed it from Win7 Professional SP1 to Win7 Ultimate but this give me no result. I am student and a part of my exercises was to create this layer anyway. Another part of the exercises was to create raster from point feature with interpolation tools /Kriging method/. So I create the layer but choose my output raster to be in a default geo database created from the software itself. This was easy job and i have no problems. Few weeks after that I decide to try again to load the raster but I decide to load it in the default geo database where was my kriging output surface layer. AND IT WORKS...
... my explanation is that the software creates some files that are needed for loading the rasters and ones it create it there are no problems with loading raster layer anywhere you choose. Hope this will help for anyone. Please excuse me for my bad English
0 Kudos