Geocoding Results - Nothing on the map using the Geocode Addresses tool, but good foR

310
4
Jump to solution
06-20-2014 08:28 AM
Highlighted
Frequent Contributor
I created a Address Locator (its Reference data is a Polyline M FC) in Single Field style.  It works fine in geocoding on ArcMap session.  When I typed a valid place name, a polyline flashed on the map.
Then, I followed ESRI procedure: http://resources.arcgis.com/en/help/main/10.1/index.html#/in_ArcMap/002500000026000000/.
1)  Loaded a data table.
2)  Opened Geocode Addresses on the data table.
3)  In PlaceName, select either None or a valid attribute name.
4)  In Advanced Geometry Options, selected 'use the map's spatial reference'.
5)  In Geocoding Options, I checked on the X and Y coordinates.
6)  Clicked OK to implement the process.
A point FC was generated as the results.  But its graphic view showed nothing on the map even though it also showed 98% match.  In the result FC table, the X & Y values are 0.
However, if I run the Display Route Events tool on the table either a Point or Line event, the generated point/line FC displayed the results properly.
If you know why, could you explain?  Thanks.
Tags (3)
Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Frequent Contributor
Using the procedure posted, I eventually got 100% match (including only a few tied) for the source data with near 3000 record.  The error does show any more.

View solution in original post

Reply
0 Kudos
4 Replies
Highlighted
Frequent Contributor
I tried several times more.  The general observations are summarized below:
1) For such a Address Locator that was generated based on a Polyline M FC, using the Geocode Address tool can't geometrically create points since the Key field selected is for line feature definition.
2) The Display Route Events can be applied for either point or line event feature class generation.  For the scenario for point event FC, the Measure field selected can be either From_Measure or To_Measure, which defines a point.   For the scenario for line event FC, the Measure fields selected are both From_Measure or To_Measure, which defines a segment.
If you have different observations, please share.  Thanks.
Reply
0 Kudos
Highlighted
Frequent Contributor
A couple of errors in my posted threads: 0 and 1:
1) After entering a valid place name, a point, rather than a polyline, flashes on the map.
2) The Geocode Address tool works and a result table can be generated.  For each valid place name, its center point's X and Y values are populated in the result table and also displays on the map.
3) The Display Route Event tool functions differently from Geocode Address tool.
Reply
0 Kudos
Highlighted
Frequent Contributor
An error in my posted thread: 0:  After entering a valid place name, a point, rather than a polyline, flashes on the map.
Reply
0 Kudos
Highlighted
Frequent Contributor
Using the procedure posted, I eventually got 100% match (including only a few tied) for the source data with near 3000 record.  The error does show any more.

View solution in original post

Reply
0 Kudos