Geocode streets without knowing ZIP

4524
6
09-24-2010 06:54 AM
Highlighted
New Contributor II
In previous versions of the software there was an address locator named US Streets that would let you geocode without knowing a zip code (provided you had the street, city and state).  Version 10 has reduced the number of locators...and I don't see a comparable locator that doesn't require zips.  As I recall, version 9 had a "US Streets" as well as one named "Streets with Zone" (if you had zip codes).

I have a large number of address for Providence, RI, but don't have zip codes; Providence is divided into several zip codes, so I can't just assign a single zip code to my data.  Is there a way to geocode my addresses?

Thanks for any help on this,

Mark
Tags (2)
Reply
0 Kudos
6 Replies
Highlighted
Esri Regular Contributor
Hi Mark

When you create a locator using a 10 style you may set the relevant zone field to <None> and not specify it at run time - in your case ZIP.  There is an issue with 10.0 which requires that at least one zone field must be non-null, but this is fixed at SP1.

Regards
Reply
0 Kudos
Highlighted
New Contributor
How do I geocode addresses in 10.1 without having zipcode field in address table. I created an address locator in 10.1 with Dual Ranges address locator and I point it to none for zone dropdown menu option but still couldn't able to geocode addresses. Please let me know.
Thanks,

Havan
Reply
0 Kudos
Highlighted
Esri Frequent Contributor
It sounds like you're running into NIM081790.  Check the workaround and see if it works for you.
Reply
0 Kudos
Highlighted
New Contributor
Hi,

I created a zipcode column in my excel sheet and left it blank. Just chose this blank zipcode column and continue geocoding, you should be able to do it. Hope this helps.

-Nisha
Reply
0 Kudos
Highlighted
MVP Esteemed Contributor
It sounds like you're running into NIM081790.  Check the workaround and see if it works for you.


The bug was submitted on Jun 15 2012: when was 10.1 released?  Shortly there after, wasn't it? 

And the fix is still a work around?

Hmmmm.
Reply
0 Kudos
Highlighted
Esri Regular Contributor
The behavior you described does fit NIM081790, which has also been discussed in the thread titled Geocoding-10-vs-10.1. I recently posted a response to a question about whether this bug will be fixed or not. Please see my response at http://forums.arcgis.com/threads/61960-Geocoding-10-vs-10.1?p=284440&viewfull=1#post284440.

-Shana
Reply
0 Kudos