Different Composite Locator Results in Geocode Service vs. ArcMap

331
4
12-11-2013 04:16 AM
Highlighted
New Contributor
I have a composite locator that was created from building points (US Single House Addresses) and streets (US Dual Range Addresses).

The building point locator appears first in the composite locator because it is inherently more accurate.

When I use the composite locator in ArcMap it correctly lists the addresses from the building points first and the addresses from the streets second when it finds a match.

This is the desired result.

When I publish the composite locator as an ArcGIS service it lists the addresses from the streets first and the addresses from the building points second which is the opposite of what is needed.

This was done using ArcGIS 10.1 SP1 and ArcGIS Server 10.1 SP1 with the data in an SQL Server 2008 R2 geodatabase.
Tags (2)
Reply
0 Kudos
4 Replies
Highlighted
Frequent Contributor
Mark,

What is the order of your locators in the composite locator? If your point locator is first, it should stop when it finds a match there.

Tim
Reply
0 Kudos
Highlighted
New Contributor
The point locator is first.
Reply
0 Kudos
Highlighted
New Contributor
I pulled the trigger too early on this issue.

It turns out that the 3rd party application that was using the geocoding service was at fault.

I used the geocoding service from within ArcMap and it returned the correct results - building address first, street address second.

The third party application returns street address first, building address second.
Reply
0 Kudos
Highlighted
Frequent Contributor
Im glad you found the problem!
Reply
0 Kudos