dbf file has a pdf that needs to change to the proper file ?

760
14
Jump to solution
09-18-2018 07:58 AM
Highlighted
Regular Contributor II

Can anyone out here help me to get the proper files to fix this ? I had no clue how it got it to PDF ?

See the red circle I drew it.  It is a .dbf  file and it is a database that was saved when I create a shapefile...

Tags (2)
Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Regular Contributor II

I'd like to thank you everyone here.... I was able to get my pdf reset to back to where it was like before I accident hit the pdf to set as a file asscioate with the dBase file....

Well I was able to get that fix and I just went into this site:

https://www.google.com/search?q=file+type+change+back+to+unknown+application+windows+10&sa=X&ved=2ah...

I was able to open it in ArcCatalog and make sure it can read it.  Yes it reads it just like exactly what you see it .

Here is the screenshot..  I havehighlighted as yellow color to show it to you...

View solution in original post

Reply
0 Kudos
14 Replies
Highlighted
Esri Frequent Contributor

might need to change the default program that is associated with .dbf files.

https://www.cnet.com/how-to/how-to-set-default-programs-in-windows-10/

--- George T.
Highlighted
Regular Contributor II

This is good however it doesn't really tell me how to change the file...  if you go to number 5.  it shouldn't be set to default.. it should have said  "Associate a file type or protocol with a specific program"  This is where you want to change from pdf to another  file.  This is what I am asking for...

Now my question to you ...is which associate type file for me to change to ?

This might be a good for others who are not sure how to change before they corrupt their files.

Reply
0 Kudos
Highlighted
MVP Frequent Contributor

Well also see that the *.shp part of the shapefile is associated with some other program as well.

Not sure that this really matters. What other program (not the file explorer) are you going to open / add a shapefile other than ArcMap or ArcCatalog?

Reply
0 Kudos
Highlighted
Regular Contributor II

Yes you are right. ..but what if you need to zip it and give to someone else ??? That is one reason I asked for to change to get it back to default.

Reply
0 Kudos
Highlighted
Regular Contributor II

I googled it and found this....

ArcGIS Shapefile Files Types & Extensions 

so .,dbf is an associate with MS Access or Excel... so I would set it as MS Access ?

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

If it is part of a shapefile... I would strongly recommend NOT editing or messing with the dbf in any other program.

Highlighted
MVP Frequent Contributor

So, unlike Dan... I rarely deal with shapefiles, but they do have their uses.

If you are zipping the whole shapefile in the file explorer, you must be careful to include all the components...

"Fred.shp", "Fred.shx", "Fred.prj", "Fred.dbf" as a minimum. There are other bits. Just select all files starting with "Fred", right click and send to a zipped file.

Reply
0 Kudos
Highlighted
New Contributor III

Sorry, that cnet article is 2 years old..which is an eternity for Win10...the option isn't even in the 'System' section anymore. A more up-to-date description I found at  https://www.lifewire.com/how-to-change-file-associations-in-windows-2624477. But there isn't an easy method to de-associate a filetype from every standard app provided by that 'user-friendly' (or should I say user-infantilizing) OS.

However, it's only a matter of taste. If Acrobat is associated with .dbf, no harm is done. Nothing happens, as long as you don't double click a .dbf. Then, if you do that, Acrobat tries to open that file, and fails. Again, no harm done.

Of course, nobody should edit or manipulate a .dbf, although it is possible, if done very carefully.

Reply
0 Kudos
Highlighted
Regular Contributor II

You are right about the double click and it comes up and it fails just like you mention.  I did asked somebody from my agency for help but he told me not to touch or mess around it... So I just leave it at it.  So the link you sent to me.. I will give that a try... Thanks.

Reply
0 Kudos