Attribute Assistant - Generate_ID - Rolls over after more than 1000 features and keeps going

3712
3
04-30-2015 06:47 AM
Highlighted
Occasional Contributor

Hi there,

 

I am trying to populate a Facility ID in a feature class that has 7000+ features using Attribute Assistant and Generate_ID as the value method. This works great if I manually select less than 1000 features and run the create rules for selected features.  As soon as I select 1001 features or more and run the create rules for selected features, the rule starts over again and continues generating facility ID's in a sequence.  It will eventually stop.   

 

Here is the Value Info:  swInlet|4|SWIN-[seq]

On create = True

On Change (attribute) = False

On Change (geometry) = False

Manual Only = False

 

Before I attempt to rerun I change the Sequence Counter in the GenerateID table back to 0.

 

The good news - I have already run the rules and created the Facility ID's less than 1000 at a time so my feature class is populated and I can move on.

 

I just want to know why it is doing this...

 

Thanks!!

-Jessica

Reply
0 Kudos
3 Replies
Highlighted
New Contributor

Was this ever answered?  I'm working on similar issue with 5600+ records and it would help to know how best to proceed before I begin using the create rules.

Thank you,

Tamara

Reply
0 Kudos
Highlighted
Occasional Contributor

Hi Tamara,

It has been a while since I worked on this and we did manage to fix it.

Let me dig around and see if I can find the answer.

If not, I can connect you to my ESRI rep who may be able to help.

-Jessica

Jessica Gooch

Water Resources Asset Manager

City of Portland, ME

jag@portlandmaine.gov

207.874.8495

<JAG@portlandmaine.gov>

**please don't print this email unless you REALLY have too***

Highlighted
Occasional Contributor

Hi Tamara,

This may be a case of better late than never...

Here is the resolution that we came up with during my support case with ESRI

"Issue is reproducible hence log the following bug. The workaround for this issue is to manually select records(click on the first record, hit SHIFT key, then click on the last record) instead of using Switch Selection button.
----------------------------
BUG-000087803 : ID generated for versioned data stored in the SQL Server geodatabase using Attribute Assistant tool cycled twice if the data contains over thousands records."

Not sure if that is helpful to you.

-Jessica

Reply
0 Kudos