Include the archive table when doing a feature class to feature class copy

446
4
09-29-2011 02:54 AM
Status: Open
TimLangner
Regular Contributor
Hi there

Currently when doing a feature class to feature class copy the archive table, containing the history of changes is not copied. All the delta tables and versions , such as the additions and deletions are copied but not archive table is not. By allowing the archive table to be copied, it would allow more robust copying of data.

I am currently working using ArcGIS 10.0.2, connecting to a geodatabase held in ArcSDE 9.3.1, with the data stored in Oracle 10g,

I am about to implement a backup which ones a day creates a duplicate copy of a database table. This would allow me to restore the data if someone accidentally deleted the table or rows of data in the table. Although Oracle is backed up, this is a quicker solution, than contacting my IT support, who do not have GIS knowledge or knowledge of ArcSDE.

However I cannot do this because the feature class to feature class copy does not copy the archive. Having spoken to ESRI (UK), they believe it will have been designed this way. I feel the design needs to be modified. If you have similar issues then please comment on my post or add your support by promoting this. The more support this gets, the greater the chance of ESRI implementing it.

If you wish to know more about archive then see this link:
http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Geodatabase_archiving/0027000000450000...

Kind regards
4 Comments
GlenColgate1
In a wider sense it would be beneficial to allow importing of any previous archive data into a recreated feature table. For instance, we have come across several situations where we were required to alter our features definition which in turn required us to bring disable archiving and unregister as versioned. After fixing the table, reregistering, and enabling the archvie we are left with no history. It should be possible to load the resulting _H tables into the active archive.
PetrUrban1
We are in the similar situation, we had to copy data from 9.2 database to newly created 10 database, so losing the history. Now we are about to find out, how to (in the worst case) programatically reconnect (create and populate with history data) the history tables. Did anyone go this way? Any experience is highly appreciated.
urban@arcdata.cz

TimLangner
Clearly, given the number of people who voted on this idea, most people don't think it that important which is a shame as ESRI probably won't see any point in implementing it.
LaurentHabyarimana1
no comment