Issues with embedded app in IE 11

723
2
Jump to solution
11-26-2018 12:06 PM
KateNewell1
Occasional Contributor

This page: Public Art Collections works just fine in Edge and Chrome but the map/data in the app will not load in IE 11.

It contains an embedded web app (Minimalist) using an iframe.  

The web app itself ( https://bellingham.maps.arcgis.com/apps/Minimalist/index.html?appid=fe09914d899740d18ca03ac6f5592cff  ) works just fine in IE 11, but not in an embedded environment.  Any suggestions? Could it be Sharepoint/IE issue?

IE Version 11.345.17134.0

0 Kudos
1 Solution

Accepted Solutions
KateNewell1
Occasional Contributor

Turns out if I remove the custom Vector Tile Basemap that I created and use in the web map that feeds the web app, it will work as embedded in IE 11.  Some combination of being embedded and not being able to render Vector Tiles...the web app works fine in IE 11 (with Vector Tiles) as a stand-alone (not embedded).  But once in embedded, it won't render the web map ( bc of Vector Tiles).  Also could be due to the fact that we use SharePoint (or so IT tells me).  My guess is that the Vector tiles file is too big too render in IE?

View solution in original post

0 Kudos
2 Replies
KateNewell1
Occasional Contributor

Here are the errors from the Developer Tools/Console for both Chrome (which works but still shows errors) and IE, where the map doesn't render...

Chrome:

IE:

IE

0 Kudos
KateNewell1
Occasional Contributor

Turns out if I remove the custom Vector Tile Basemap that I created and use in the web map that feeds the web app, it will work as embedded in IE 11.  Some combination of being embedded and not being able to render Vector Tiles...the web app works fine in IE 11 (with Vector Tiles) as a stand-alone (not embedded).  But once in embedded, it won't render the web map ( bc of Vector Tiles).  Also could be due to the fact that we use SharePoint (or so IT tells me).  My guess is that the Vector tiles file is too big too render in IE?

View solution in original post

0 Kudos