Refused to display <<URL>>in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'.

5062
4
11-22-2015 08:01 AM
ABHISHEKSINDAL1
New Contributor II

While embedding code in StoryMap Journal template, taken from CityEngine viewer, getting following error. Where do we need to make changes? IIS manager or in embedding code? and what changes?

Error: Refused to display <<URL>>in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'.

Please suggest.

0 Kudos
4 Replies
GregoryL_Azou
Regular Contributor II

Are you using Portal for ArcGIS?

In ArcGIS Online it seems to works for me, see this Journal http://www.arcgis.com/apps/MapJournal/?appid=01c40e1ac2924c33a663c8731f80595e that embed this scene http://www.arcgis.com/apps/CEWebViewer/viewer.html?3dWebScene=2e71f229901a401c9a73560975a144e7

If you are on Portal, it must be that the Portal is configured to not allow a scene to be embedded in application. That would be a setting to change at the web server level. I suggest that you contact Esri technical support Esri Support

ABHISHEKSINDAL1
New Contributor II

We are also using AGOL Org acc. Thanks for your help.

0 Kudos
GeorgeVernardos
New Contributor III

I have a scene in Portal for ArcGIS, and need to publish it through an iframe at a site with different domain, so I am stuck in the situation described above. I tried to tweak iis, no luck...

If anyone has done this, please enlighten the rest of us.

0 Kudos
StephenSylvia
Esri Regular Contributor

Is your web scene shared public? If you are attempting to embed any ArcGIS online/portal templates or web scenes, they must be shared publicly. If they are private or shared only with and org/group, the applications will first redirect to a login page. For security reasons, this login page is not allowed to be embedded.

0 Kudos