GPS error code 5

7275
18
09-07-2010 10:03 AM
JeffTimm
Occasional Contributor
If the GPS is disconnected or the GPS connection is dropped during an ArcPad session I receive the following errors: 1)"An error has occurred connecting to the receiver (error code 5)..." and 2) "Failed to connect to the GPS receiver because the COM port is in use by another application."

Sometimes if I restart the trimble unit it will work again and sometimes it won't. Does anyone have any ideas??

GPS/GIS software and hardware: ArcPad 8.0 sp4 with GPScorrect 3.02 on a Trimble GeoXH 2008 Series.
Tags (3)
0 Kudos
18 Replies
D3EGPS
by
New Contributor III
Hi,

I think you should contact directly your Trimble Reseller if it occurs too often.
Indeed this problem is perhaps due to a problem of your GPS main card within the Geo.
If you have the error 5 message you must use either GPSCorrect or GPSController to test the connection. This problem happens also in GPS Controller ?
It happened on my Geo units and this is either or problem of low temperatures or GPS card to my mind.

For  the busy COM port, did you check the internal GPS settings of the Geo (start/Settings/System/GPS) and uncheck every settings. Indeed the GPS Protocol and settings are defined by GPSCorrect not Windows.

Contact Trimble and they will tell you exactly what is going on.
Hope that helps

regards

Julien
0 Kudos
JeffTimm
Occasional Contributor
I have 3 different GeoXH units that do this.  It seems to happen with larger datasets.  I am wondering if it is a memory issue and if there is a fix.
Julien, I have unchecked the Windows GPS setting like you suggested and no change.

I saw in the old forums that a few others were having this problem but no one replied to their post.
0 Kudos
D3EGPS
by
New Contributor III
Hi,

With ArcPad 8 and High Resolution screens it has, till the beginning, been a difficult combination.
It is perhaps a memory issue regarding the size of your datasets.

There was a patch for Highres screen : http://arcscripts.esri.com/details.asp?dbid=14683
Maybe you should try this. Just copy the ArcPad.exe file from the Geo to your laptop. Use the HighRes.exe file to patch it and copy back the ArcPad.exe file to the device.

Try with this...maybe...
I did not test it with ArcPad 8.0.4 cause I am now using ArcPad 10...

Did you test the GPS connection with GPS Controller ? Just connect the COM3 of the Geo to GPSController and check if you have the same error after some time.

Did you contact your Trimble reseller ? What did they say ?

Regards

Julien
0 Kudos
ZoltanKovacs1
New Contributor
Hi,

That is a common issue on every Windows Mobile device with - usually more than one - GPS software installed. Sometimes a process just stuck in the memory and the system think that GPS is still in use. Do a soft/hard reset, it should solve your problem.
Trimble won't advise anything else, this is an official troubleshooting tip you can find in every Trimble MGIS getting started guide.

Hope this helps,

Zoltan
0 Kudos
JeffTimm
Occasional Contributor
I have already run the hi res patch.  Didn't help.  I contacted my trimble reseller and they picked up one of my units and said there is nothing wrong with the trimble.
0 Kudos
D3EGPS
by
New Contributor III
Hi Jeff,

Then, as Zoltan said, it is probably the WM issue....
I contact Trimble support concerning a similar issue (COM3 issue on a Geo - Similar to your port Com is already issued by....) and they answered that it also can happen if you do not disconnect properly the GPS in ArcPad from GPSCorrect....
It was not for a large dataset so the only workaround was to reset the device and try to connect GPS again

Sorry, but if it can helps 😞
0 Kudos
ericbock
New Contributor III
Sounds like you've tried some of these, but go through the list and check.

ArcPad 8 Best Performance

1) 2008 GeoExplorer Series Windows Mobile Operating System 6.1 Update

2) Install ArcPad 8 Service Pack 2 or higher

3) Error Code 5 Fix - maybe

a. Install the Priority Script
i. The Priority script that ships with ArcPad allows us to modify the priority of the thread that�??s doing the redraw.  The script is installed in:  Computer Drive with ArcPad Installation C:\Program Files\ArcPad 8.0\Developer\Samples\Applets.

ii. If you copy the script to \Program Files\ArcPad\Applets on the geo and restart arcpad, you�??ll see a little extra item in the tool bar �?? looks like the ArcPad logo.  Activate this tool bar and click the one icon that appears to run the script.

iii. Then change the drawing priority from �??abovenormal�?? (the default) to �??normal�??, hit OK and quit ArcPad.

iv. Restart Arcpad and the new setting will take affect. The change allows the GPS to keep working during the redraw.

4) High Res Patch for VGA Screens
a. Slow performance on some high resolution devices when using GPS �?? When collecting data using GPS on some high resolution devices (eg: Nomad, 2008 GeoExplorer), you may observe a slow response from ArcPad. To improve the performance of ArcPad on these devices, you may benefit from running the ArcPadHiRes utility. This can be downloaded at http://arcscripts.esri.com/details.asp?dbid=14683

5) Uncheck extensions not being used in the advanced options

6) May be a feature class issue
a. Try checking out one feature at a time to find out the culprit.
b. If you find the problem feature class, create a new one and import the data

7) If possible, try reducing the amount of data you are checking out

Eric B
0 Kudos
NormWray
New Contributor II
Hi all,

I've been having the "GPS ERROR 5" code almost every time I use my GeoXH handheld.  So far, the only thing that has worked for me is resetting the device until the GPS eventually works in ArcPad.  The post from Eric B. on 09-16-10, however, has helped me fix the problem. 

I downloaded and installed the High Res patch per the instructions, but that did not seem to work.  I then copied over the "Priority Script" and changed the drawing priority to "normal" per his recommendation.  This has appeared to work for me as I have not yet had an error since changing the priority.  A warning on the fix; it definately slows down the re-draw performance of your maps.  It is very noticable when you are using a large data set (in my case, a full city parcel map).  Still worth it just to have the GPS functional.

I do have a question on the priority script though.  The script allows you to change the priority for two things; the draw priority and the GPS priority.  Could you leave the draw priority at above normal (to keep the drawing speed relatively high) and simply set the to the GPS to the "highest" priority?  I'll be testing that our over the next week to see if there are any issues with it.

Norm W.
0 Kudos
JeffTimm
Occasional Contributor
Sounds like you've tried some of these, but go through the list and check.

a. Install the Priority Script
i. The Priority script that ships with ArcPad allows us to modify the priority of the thread that�??s doing the redraw.  The script is installed in:  Computer Drive with ArcPad Installation C:\Program Files\ArcPad 8.0\Developer\Samples\Applets.

ii. If you copy the script to \Program Files\ArcPad\Applets on the geo and restart arcpad, you�??ll see a little extra item in the tool bar �?? looks like the ArcPad logo.  Activate this tool bar and click the one icon that appears to run the script.

iii. Then change the drawing priority from �??abovenormal�?? (the default) to �??normal�??, hit OK and quit ArcPad.

iv. Restart Arcpad and the new setting will take affect. The change allows the GPS to keep working during the redraw.

Eric B


Thank you Thank you Thank you...The priority script fixed my issues.  I am suprised with all the time that I spent with customer support that this was never mentioned. Thanks.
0 Kudos