Web Site not displaying Map Control (WebADF, VS 2008 c#)

236
1
12-04-2012 10:45 PM
Highlighted
New Contributor
Hi all

I'm trying to develop an extranet GIS application web site for my client using the WebADF tools in VS2008 C#.

Everything is installed on a stand-alone box (Server 2003).

When I add a Map Resource Manager and Map control to my 'New ASP.NET Website' it can read the layers from ArcGIS Server local no problem. However, when I run the app the map control does not display. There are no errors.

Other tools such as Toolbar do display therefore I assume it's a permissions issue whereby the WebADF can go and read the layers but can't bring them back to display in the browser. I've set all Code Groups in .NET framework to 'Full trust' and still no joy. This is driving me mad!

Any ideas?

Thanks,
Tom

Just to add, I've looked at the Event Viewer in Windows and found this DCOM error: 10016. I've granted permissions in the ASP.NET framework configurator but still no map display.
Reply
0 Kudos
1 Reply
Highlighted
Esteemed Contributor
Tom:

Do your business needs require that you use the web adf to build your application?

ESRI is deprecating the web adf so I would try to avoid building a new application with this architecture.

I would suggest trying the FlexViewer as there are many compiled widgets out there that are configurable to be able to meet many business needs.

Hopefully, you are at least at ArcGIS v10.0 where the capability is vastly improved compared to ArcGIS v9.3.1.
Reply
0 Kudos