License level requirements for add-in deployment

284
2
05-29-2014 12:00 PM
EvanBlaisdell
New Contributor III
Hello,

I am running Advanced (ArcInfo) and I am developing an add-in that will be deployed to multiple computers around the company.  We need to know what license level each machine should be running.  Is there a way to determine if an add-in will work on a computer with a lower license level, without physically installing and trying every possible function of the add-in on the target machine to see if it will fail?  Will an add-in developed in Advanced run in Standard?

Thanks,
Evan
0 Kudos
2 Replies
NeilClemmons
Regular Contributor III
As far as I know, there is no comprehensive list that maps license levels to functionality.  If your application has a requirement that it run under a certain license level then you should be developing and testing under that same license level.  This will keep you from writing something that requires a higher license level.
0 Kudos
EvanBlaisdell
New Contributor III
As far as I know, there is no comprehensive list that maps license levels to functionality.  If your application has a requirement that it run under a certain license level then you should be developing and testing under that same license level.  This will keep you from writing something that requires a higher license level.


That's pretty much what I expected, thanks.  If only the "requirements" didn't change.

Evan.
0 Kudos