Workforce / Survey123 Integration: After Submiting Form Workforce Doesn't Become Active Automatically

553
2
Jump to solution
11-23-2020 07:14 PM
Billy
by
Occasional Contributor

Hi,

I'm using the latest version of Workforce for Android (App Version 20.1.1/Build 272) and version 3.11.164 of Survey123 for Android.

After connecting both app, but not passing any fields, I get an alert that for the Survey123 integration that says "Sharing permissions on form has changed" (see image below)

Then when I use the workforce mobile app to complete an assignment, I can open the linked survey but after submitting the form I have to manually open the workforce mobile app that stayed active in the background.

Why workforce doesn't open again automatically after submitting the form?

 

Billy_1-1606186865048.png

 

Billy_0-1606186777731.png

 

Reply
0 Kudos
1 Solution

Accepted Solutions
GlenShepherd
Esri Contributor

Hi @Billy ,

The "Sharing permissions on form have changed" error message will appear if the sharing settings on our form item in our web portal have changed after the integration has already been set up in Workforce.

For example, if I set up a regular integration, then go back to ArcGIS Online and change sharing on my survey form from "Organization" to "Owner"

GlenShepherd_0-1606191027605.png

Then go back to my integration in Workforce web designer and refresh the tab, then the same error message appears.

GlenShepherd_1-1606191095035.png

This is a warning that some access permissions have changed to the integrated content. So if I had users within my organization other than myself that need to access this survey, it may no longer be possible because I've changed it back to "Owner" when the integration was made at a time when it was set to "Organization"...

As for the ability to automatically re-open Workforce after survey submission, this currently looks to be a limitation of the WorkForce app... The user is currently required to manually re-open Workforce after finishing work in Survey123.

 

 

View solution in original post

Reply
0 Kudos
2 Replies
GlenShepherd
Esri Contributor

Hi @Billy ,

The "Sharing permissions on form have changed" error message will appear if the sharing settings on our form item in our web portal have changed after the integration has already been set up in Workforce.

For example, if I set up a regular integration, then go back to ArcGIS Online and change sharing on my survey form from "Organization" to "Owner"

GlenShepherd_0-1606191027605.png

Then go back to my integration in Workforce web designer and refresh the tab, then the same error message appears.

GlenShepherd_1-1606191095035.png

This is a warning that some access permissions have changed to the integrated content. So if I had users within my organization other than myself that need to access this survey, it may no longer be possible because I've changed it back to "Owner" when the integration was made at a time when it was set to "Organization"...

As for the ability to automatically re-open Workforce after survey submission, this currently looks to be a limitation of the WorkForce app... The user is currently required to manually re-open Workforce after finishing work in Survey123.

 

 

View solution in original post

Reply
0 Kudos
Billy
by
Occasional Contributor

Hi Glen,

Thanks for the reply.

 

Reply
0 Kudos