When app state is used, ellipse (...) symbol shows twice in popup.

671
3
Jump to solution
10-28-2016 06:22 AM
ChristopherSchreiber
Occasional Contributor II

Hello,

We have an app that was created with WAB 2.1 DE hosted on our web server. Whenever I use the "App State" box to return to my last extent on the app, this causes the ellipse (...) symbol to appear twice on the popup window for a feature. How do I get rid of the second ellipse? 

Thanks!

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Christopher,

   Great catch. I have not noticed this bug before. You should call it into esri tech support as it looks like 2.2 will have this issue as well.

Here is the workaround you can apply to fix this though:

In the [install dir]\jimu.js\PopupManager.js replace the _createPopupMenuButton function with this one:

      _createPopupMenuButton: function(){
        if(query(".popup-menu-button", query(".actionList", this.popupUnion.bigScreen.domNode)[0])[0]){
          html.destroy(query(".popup-menu-button", query(".actionList", this.popupUnion.bigScreen.domNode)[0])[0]);
        }
        html.destroy(query(".popup-menu-button", query(".actionList", this.popupUnion.bigScreen.domNode)[0])[0]);
        this.popupMenuButtonDesktop = html.create('span', {
          'class': 'popup-menu-button'
        }, query(".actionList", this.popupUnion.bigScreen.domNode)[0]);

        var mobileActionListNode = query(".esriMobilePopupInfoView .esriMobileInfoViewItem").parent()[0];
        if(query(".esriMobileInfoViewItem", mobileActionListNode)[0]){
          html.destroy(query(".esriMobileInfoViewItem", mobileActionListNode)[0]);
        }
        var mobileViewItem = html.create('div', {
            'class': 'esriMobileInfoViewItem'
          }, mobileActionListNode);

        this.popupMenuButtonMobile = html.create('span', {
          'class': 'popup-menu-button'
        }, mobileViewItem);
        on(this.popupMenuButtonDesktop, 'click', lang.hitch(this, this._onPopupMenuButtonClick));
        on(this.popupMenuButtonMobile, 'click', lang.hitch(this, this._onPopupMenuButtonClick));
      },

Junshan Liu

View solution in original post

0 Kudos
3 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Christopher,

   Great catch. I have not noticed this bug before. You should call it into esri tech support as it looks like 2.2 will have this issue as well.

Here is the workaround you can apply to fix this though:

In the [install dir]\jimu.js\PopupManager.js replace the _createPopupMenuButton function with this one:

      _createPopupMenuButton: function(){
        if(query(".popup-menu-button", query(".actionList", this.popupUnion.bigScreen.domNode)[0])[0]){
          html.destroy(query(".popup-menu-button", query(".actionList", this.popupUnion.bigScreen.domNode)[0])[0]);
        }
        html.destroy(query(".popup-menu-button", query(".actionList", this.popupUnion.bigScreen.domNode)[0])[0]);
        this.popupMenuButtonDesktop = html.create('span', {
          'class': 'popup-menu-button'
        }, query(".actionList", this.popupUnion.bigScreen.domNode)[0]);

        var mobileActionListNode = query(".esriMobilePopupInfoView .esriMobileInfoViewItem").parent()[0];
        if(query(".esriMobileInfoViewItem", mobileActionListNode)[0]){
          html.destroy(query(".esriMobileInfoViewItem", mobileActionListNode)[0]);
        }
        var mobileViewItem = html.create('div', {
            'class': 'esriMobileInfoViewItem'
          }, mobileActionListNode);

        this.popupMenuButtonMobile = html.create('span', {
          'class': 'popup-menu-button'
        }, mobileViewItem);
        on(this.popupMenuButtonDesktop, 'click', lang.hitch(this, this._onPopupMenuButtonClick));
        on(this.popupMenuButtonMobile, 'click', lang.hitch(this, this._onPopupMenuButtonClick));
      },

Junshan Liu

View solution in original post

0 Kudos
ChristopherSchreiber
Occasional Contributor II

Thanks Robert!

I will call Esri about this.

Chris

0 Kudos
ChristopherSchreiber
Occasional Contributor II

Just to Update,

I contacted Esri Support about this issue and a bug was created.

Bug Number: 000100499

In Web AppBuilder, an extra set of ellipses appears in pop-ups when using the 'App State' feature to return to the last extent of the application before it was closed.

Thanks,

Chris

0 Kudos