Web AppBuilder does not honor relationship table?

5037
9
Jump to solution
02-11-2015 08:47 AM
StevenKincaid
New Contributor III

I'm serving (locally not hosted) a parcel feature class along with it's associated data via relationship table as a feature service.  When I create my web map using this feature service, I configure my pop-up it seems to honor the one to many relationship i.e. one parcel with multiple addresses.  When I create a map application using the Web AppBuilder, I can no longer see the one to many relationships in the pop-up.  Does anyone know if this is a bug or possibly I have this configured incorrectly.  I am unable to provide a link to the map application as we currently do not have a public facing server, and you will not be able to see the parcel feature service.

Thanks for the help.

Steve

1 Solution

Accepted Solutions
StanMcShinsky
Regular Contributor

From what I have read and looks like you have confirmed is that related tables are not part of WAB yet. Related tables work on ArcGIS Online and now collector but not WAB. I am sure that will be coming soon.

View solution in original post

9 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Steven,

   Sounds like a bug that needs to be reported to tech support.

MattEitrem
Occasional Contributor

Try making sure the relationship class is created in the mxd and the table resides inside the mxd before publishing the service. Kind of a long shot, but I have had issues in the past with using gdb based relationships in services and having connections issues that showup in the web apps.

StevenKincaid
New Contributor III

Matt & Robert,

Thank you for the advice.  The feature class and the relationship table are both stored in SDE, but when I went to create my service, I included the relationship table in the mxd.  My rest end point does show me that I have a related table.  It's just funny how the pop-up was working perfectly in the web map and not in the application which is using the web map.  Which makes me think it's a bug?

Top image is the Web Map, bottom is the application

WebMap.jpgApplication.jpg

StanMcShinsky
Regular Contributor

From what I have read and looks like you have confirmed is that related tables are not part of WAB yet. Related tables work on ArcGIS Online and now collector but not WAB. I am sure that will be coming soon.

View solution in original post

ClintGarrison
New Contributor

I think I ran into the same situation. I made an mxd with a related table. I made a AGOL MAP and the relates are there. But when I Hit SAVE AS and then make an application - basic viewer template - the relate isnt there.

I know people switch the terms AGOL MAP and APP when they talk, but can anyone verify they have an AGOL APP that has relates? I havent tried collector yet or WAB. And along those lines, if we use WAB directly from the AGOL screen on a smartphone, does the Relate work still?

Thanks,

Clint

0 Kudos
StanMcShinsky
Regular Contributor

I have not tested it yet, but it looks like the new update of AGOL (March 2015) now supports related records in popups. Can anyone verify this works as expected?

Web AppBuilder for ArcGIS | ArcGIS

0 Kudos
deleted-user-YYhuCJuuEn9L
New Contributor III

There doesn't appear to be a drop down like in AGOL. Clicking on Show Related Tables opens all related tables in the Attribute Table widget. This is not ideal when multiple relationships exist.

NartTamash
New Contributor III

Same problem here! Ideally you want the same behaviour as in AGOL with selected map feature popup > Show Related Records > Popup with list of related tables > pick the table you want to view the related records for > Open table in Attribute Table widget.

I also seem to get some weird formatting issues with related tables names & column names, when they open (i.e. overlapping text on column names and original database table name as opposed to alias).

0 Kudos
JacquelineKovarik
New Contributor III

Hi Stan,

I've deployed web apps through the Developer's Edition of Web Appbuilder that retain the same functionality as an AGOL web map (click on a feature and a "Show Related Records" link displays in the pop-up window). I have not had any success with getting related tables to appear in the pop-up window if I create a web app with the standard edition of web appbuilder through AGOL.

I would hope this is a high priority "bug" that Esri is working on!

Jacqueline