WAB Smart Editor - did the Dec 5th AGOL update break attribute data entry tabbing functionality?

715
10
Jump to solution
12-18-2018 08:46 AM
BrianFausel
Occasional Contributor III

We use the Smart Editor widget in our Web AppBuilder apps and when editing the attributes the "tab" function recently stopped working. I'm referring to the standard data entry functionality where you can use the "tab" key to move to the next line between attributes.

This was working at some point in the past but is now broken. When you tab it highlights the template box instead of the next line. Our users think it stopped working around the last AGOL update on Dec. 5th. We are using the hosted WAB on AGOL, not the Enterprise or Developer version.

The "tab" functionality still works in the standard Editor widget, but we like the added functionality in the Smart Editor and hope it will be fixed.

1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Reporting the issue to esri tech support is the best route for ensuring this gets fixed.

View solution in original post

0 Kudos
10 Replies
BrianFausel
Occasional Contributor III

Thought perhaps it was a browser issue but the problem is experienced in Chrome 71, Firefox Quantum 64 and IE 11.

0 Kudos
deleted-user-vgwFLiUByf_j
New Contributor

I've definitely experienced this issue and first encountered it right after the December update. I tried four different browsers as well, with no results. Hopefully this will be fixed by the next update. 

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Reporting the issue to esri tech support is the best route for ensuring this gets fixed.

View solution in original post

0 Kudos
BrianFausel
Occasional Contributor III

Thanks Robert and Corey. I have set up a test editor app and the tabbing problem still persists. I'll open a support ticket with Esri and will report back what I hear...

0 Kudos
BrianFausel
Occasional Contributor III

This is a known problem, my support case has been attached to BUG-000118826: Unable to tab between fields when using the Smart Editor widget in Web AppBuilder for ArcGIS.

JeffreyROLAND
New Contributor III

Brian, thanks for this. I had noticed this issue too and it is very annoying. Hopefully it will be fixed in the next update.

0 Kudos
KyleWikstrom
Occasional Contributor II

We are experiencing this issue as well. A workaround that we are using is adding the Edit widget, but our users are not taking advantage of all of the Smart Editor capabilities so they only trade-off they experience is editing attributes in a popup vs a "side panel".

0 Kudos
BrianFausel
Occasional Contributor III

Yes we are also back to using the standard Edit widget as well, which our users definitely find annoying. I was hoping Esri would fix this with the March update but it still appears to be broken (though interestingly back tab shift + tab still works).

KyleWikstrom
Occasional Contributor II

Yes, still experiencing this after the March release.

0 Kudos