Vector Tile Basemap not supported by WAB Overview Map widget?

216
3
02-24-2021 07:36 AM
Labels (1)
ZachBodenner
New Contributor III

I have a web map in my organization's enterprise portal that uses a hosted vector tile layer as a basemap. I'm building an app using Web AppBuilder that utilizes the Overview Map widget. However, though the Overview Map widget is set to Display: This Map's Basemap, the widget seems to only want to utilize one of ESRI's standard basemaps. 

One thing I can  get to work is using a custom basemap that was constructed using a cached service from our local aerial imagery, which tells me that the actual widget is responding to changes, but for some reason does not want to honor the vector tile layer basemap. Is this a known issue? Does the Overview Map widget not support vector tiles?

0 Kudos
3 Replies
ShelleySchott
Esri Contributor

@ZachBodenner , there is a BUG-000128443 currently against the Overview Map Widget in ArcGIS Enterprise 10.7.1 where  an overview map (other than the basemap) can only be added if the basemap and the other overview map are in the WKID 102100 coordinate system.

The workaround is to use a map with the WKID 102100 coordinate system.

Is your vector tile layer projected in WGS84 Web Mercator (Auxiliary Sphere)?

 

Senior Consultant, Esri Australia
0 Kudos
ZachBodenner
New Contributor III

Oh thanks Shelley, that's good information to have! According to the REST endpoint of the hostel vector tile service, yes, it is in fact in 102100.

I use this vector tile layer as the basemap in the map, so I'm not quite sure why an overview map targeting the same vector tile basemap wouldn't work if they're both in the same WKID.

Is there any more to that workaround?

0 Kudos
ShelleySchott
Esri Contributor

No problem,

I can't find anything that specifically mentions vector tiles. I would log a support case with your local Esri office to look into that further.

Senior Consultant, Esri Australia