Query Widget: Time removed from Export

233
3
06-08-2018 08:30 AM
ErickWiggs2
New Contributor III

Howdy,

I'm using the online Web AppBuilder for ArcGIS to create a reporting dashboard. I set up the Query Widget to help the end user query my feature service and return results.

All of that is working fine, except that when I use the export to csv function it strips all of the times off of my date/time attributes.

I've checked the services I published, the webmap feeding the web app, and the database. All show correct date/ time in the attribute field. When I look at individual pop-ups, I see the date/ time; in both the web map and web app. When I look at the data in the Attribute Table within the dashboard - I see date/time, and when I export from the attribute table widget I see date time. 

From what I can tell, the query widget doesn't support showing times from the queried feature service? Or am I missing something?

0 Kudos
3 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Erick,

   There is no configuration that you are missing it is just a limitation of the current widget. You should contact esri tech support and file an enhancement request for this.

0 Kudos
jchester73
New Contributor III

Has this feature been added yet? It's important that the time stamp be included in exports in a full date and time format, not just from the main attribute table but from queries as well.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Not that I am aware of. Enhancement requests will gain more weight if you call it into esri tech support too. 

0 Kudos