Layer not showing up in print

2175
2
Jump to solution
03-21-2019 01:59 PM
AmyRoust
Occasional Contributor III

Web link: ArcGIS Web Application 

I've "upgraded" a few of my maps to WABDE ver 2.11, and am having an issue with the Print widget. Everything appears to work fine, but when the actual JPG/PDF/PNG is created, the parcel layer does not show up. This layer is visible in the map (you have to zoom in a bit to see the orange property lines) and it appears in the Legend widget. Is this a bug or (more likely) am I missing a setting somewhere in my web map?

Screen shot -- 

Screenshot comparing web map to printed document

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
TanuHoque
Esri Regular Contributor

Amy Roust

unfortunately you are running into a bug where print service fails to draw a feature layer when its default visibility is  False in the map/feature service.

good news is that this is fixed in 10.7.

until you migrate to 10.7, you can go with one of the following options:

1. make the Parcel layer visible in your map and republish the map service

2. add your service as a mapImage layer (aka dynamic map service layer where the url ends with '/MapServer') instead of a feature layer (where url ends with '/MapServer/<id>')

hope this helps.

View solution in original post

2 Replies
TanuHoque
Esri Regular Contributor

Amy Roust

unfortunately you are running into a bug where print service fails to draw a feature layer when its default visibility is  False in the map/feature service.

good news is that this is fixed in 10.7.

until you migrate to 10.7, you can go with one of the following options:

1. make the Parcel layer visible in your map and republish the map service

2. add your service as a mapImage layer (aka dynamic map service layer where the url ends with '/MapServer') instead of a feature layer (where url ends with '/MapServer/<id>')

hope this helps.

AmyRoust
Occasional Contributor III

Tanu, THANK YOU!! Workaround #1 worked great. I had to re-add the layer to the web maps after republishing the service, but doing so resolved the issue.