How to publish the Isolation Trace Geoprocessing service from a SDE geodatabase ?

1242
8
01-06-2017 02:23 AM

Hi everybody,

Working in a water distribution company, I'm currently using a Web Application (Esri Web App Builder) in which I isolate a part of a water net from a leak or a main break thank to the "Isolation Trace" widget.

The geoprocessing works well except when I publish it from a SDE geodatabase. In this case, the Isolation Trace shows an error (joined in this message). I guess it is a problem of In_Memory parameters in the geoprocessing but not sure. I don't know if it can help you but my database Platform is SQL Server. 

Let me know if you need more information to be able to help me.

Thank you in advance

Karine

Tags (1)
0 Kudos
8 Replies
VinceAngelo
Esri Esteemed Contributor

Please always include error messages as text in the initial posting itself.  There are two reasons:

  1. Folks are more likely to read it (and therefore answer) vice a zipped text file.
  2. The question (and answer, hopefully) is more likely to be found in a free text search by others with the same issue.

- V

0 Kudos

Ok I will think about it in my next post, thank you for your advice

0 Kudos
DerekLaw
Community Moderator

Hi Karine,

I'm not clear on your issue.

Is your "Isolation Trace" widget a custom widget? or is it really a Geoprocessing (GP) widget that is referencing a GP service that performance an "isolation trace"?

In the latter case, are you saying the GP service is not working at all in the GP widget in Web AppBuilder? or something else?

The error log you attached seems to be from ArcSDE and indicates that the geometric network datasets you're trying to create already exist.

Is the "isolation trace" model you created working properly in ArcMap? And then you were able to successfully publish its execution plan to create a GP service?

0 Kudos

Hi Derek,

I don't know if I can talk about "custom widget". I only modified the IsolationTrace Model I downloaded on Esri Utility Isolation Trace, to fit my data (ie : change the coordinate system, the saving folders...).

The Isolation trace Model is working on my database ".SDE" in ArcMap but when I publish it on ArcGis Server, the GP service doesn't work in the App. In fact, the GP service IsolationTrace works on the App only when the it is published from a local database ".GDB".

Tell me if you need more explanations. Thank you already for your response.

Karine

0 Kudos
DerekLaw
Community Moderator

Hi Karine,

Can you please share the link to where you got the IsolationTrace Model?

I am not familiar with this widget - but since you modified its code, are you certain that you enabled it properly to work with data from an enterprise (aka. ArcSDE) geodatabase?

Hope this helps,

0 Kudos

Hi,

Please find below the link :

http://solutions.arcgis.com/utilities/water/help/web-isolation-trace/

Actually, I don't know if I have to activate something to work with ArcSde geodatabase ? Do you ?

Thank you for your attention

Karine

0 Kudos
TimHayes1
Occasional Contributor III

Karine, 

Are you running the layers in the Web App from the DEFAULT Geodatabase or a Replica File Geodatabase. For Web AppBuilder I run all my layers from a One-Way Replica File Geodatabase. Check our Replica Geodatabases if you are not already aware of them. If the Isolation Trace works in a File Geodatabase, then a Replica may provide the solution. 

0 Kudos

Hi Tim,

I am not sure I see what you mean, but I try to run the App from the ArcSDE geodatabase (do you consider that it's the default database?).

I would like to have nothing on my computer (so no file GDB) but everything on the server dedicated for it.

Do you mean that If I copy a File GDB on a ArcSDE GDB, It would work ?

Thank you also for your help,

Karine

0 Kudos