Error 401.3 - You are not authorized to view this page

07-18-2011 12:02 PM
New Contributor III
Not the best move on my part but I figured copying the flexviewer folder to the server's desktop would be backup enough but I was entirely wrong...

I was experimenting with my basemaps being as I have had issues adding in my own basemaps into the flexviewer. After messing around I decided to stay with the Esri basemaps I had added earlier on. I had already added over a month of customization to the viewer so I went back to my "trusty" copied folder from the desktop. When I tried to add the old folder I get the following message when trying to view the flexviewer on both the server and my machine:

"You are not authorized to view this page
You do not have permission to view this directory or page due to the access control list (ACL) that is configured for this resource on the Web server.

Please try the following:

Contact the Web site administrator if you believe you should be able to view this directory or page.
Click the Refresh button to try again with different credentials.
HTTP Error 401.3 - Unauthorized: Access is denied due to an ACL set on the requested resource.
Internet Information Services (IIS)


Technical Information (for support personnel)

Go to Microsoft Product Support Services and perform a title search for the words HTTP and 401.
Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled About Security, Access Control, and About Custom Error Messages."

Anyone have any insight into this manner? I have looked at some previous forums and have not had any success. Any insight is helpful at this point.
Tags (2)
0 Kudos
1 Reply
New Contributor III
For those who encounter this, I solved this by re-downloading the flexviewer from ESRI's website, copied the files and code that I added over the last few months from the non-functioning folder. It took a little over an hour to complete but it works just as it did before. I have no idea why it didn't work when I tried to paste it back in but it works now. 😛
0 Kudos