"More..." text disappearing from Layerlist button

999
15
Jump to solution
04-30-2013 12:51 PM
CameronBrown
New Contributor III
[ATTACH=CONFIG]23886[/ATTACH]Seeing this bug randomly on different machines.  Sometimes the text is there, and sometimes it is not.  Although it seems to happen most often on Internet Explorer.  I have not made any changes to the MapSwitcher widget.  Does anyone have any idea of why this is happening?
Tags (2)
0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor
Cameron,

   Are you manually setting the font in your main config.xml or in the default.css?

View solution in original post

0 Kudos
15 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor
Cameron,

   Are you manually setting the font in your main config.xml or in the default.css?

View solution in original post

0 Kudos
CameronBrown
New Contributor III
Cameron,

   Are you manually setting the font in your main config.xml or in the default.css?


No, neither of those files.
0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor
Cameron,

   Have those machines had the font size in the browsers increased or the standard windows DPI changed to 120? The only time I have seen that issue is when the font size is too big to fit the More... into the button.
0 Kudos
CameronBrown
New Contributor III
Cameron,

   Have those machines had the font size in the browsers increased or the standard windows DPI changed to 120? The only time I have seen that issue is when the font size is too big to fit the More... into the button.


I haven't made any font size or dpi changes.  Also, I've had several users complain about this who are not on our network.  So it's not isolated to one machine or one network.  The strange thing is that it will appear sometimes.  Then the next load (after closing out IE) it will not be there.  I just pulled up my viewer in Firefox and everything looked fine, then pulled it up in IE and the "More..." was gone.  The url is http://maps.sanbag.ca.gov/flexviewer if you'd like to have a look.
0 Kudos
JoshWhite
Regular Contributor III
I tried this map in IE, Firefox and Chrome and the More came up properly in all three.
0 Kudos
CameronBrown
New Contributor III
I tried this map in IE, Firefox and Chrome and the More came up properly in all three.


Hmmm...can't decide if this is good or bad.  Well, I just tried from IE, then on my Android browser and both time the "More..." was gone.
0 Kudos
CameronBrown
New Contributor III
I tried this map in IE, Firefox and Chrome and the More came up properly in all three.


Actually, I'm finding that if I go to the url http://maps.sanbag.ca.gov/flexviewer/index.html then I will get the error.  Going to just /flexviewer everything loads normally.  I was only loading index.html at times so that I could add a config parameter to the url.   Perhaps something is wrong with my index.html file.  However, I'm finding that everything looks normal when I try maps.sanbag.ca.gov/flexviewer/default.htm instead of index.html.  Default.htm was higher up the list in the default document priority.

So I guess everything is fixed, although I have no idea what was wrong with the index.html file.
0 Kudos
JoshWhite
Regular Contributor III
How did you get it to show up on an Android browser?
0 Kudos
CameronBrown
New Contributor III
How did you get it to show up on an Android browser?


Just put the url into the browser.  It's a little wonky but it works...a little hard to pan and zoom.  Using Android 4.2.2
0 Kudos