an error occured while trying to fetch sprite data. Ideas?

447
10
Jump to solution
05-18-2018 11:51 AM
ClayDonaldsonSWCA
Occasional Contributor

Running into an error when selecting a basemap.

An error occured while trying to fetch sprite data for item 7549fb39378a485ca0c9d18a2d968c15

Clay

Reply
0 Kudos
1 Solution

Accepted Solutions
PatrickArlt1
Occasional Contributor

I have a few more questions then:

1. Does this occur on every browser on your machine? For example Firefox, Edge or Safari?

2. Does this occur for every basemap or just a few? If so which?

3. Can you update your version of Chrome? Chrome 57 is about a year old so that might be a reason for this.

View solution in original post

10 Replies
PatrickArlt1
Occasional Contributor

Hi Clay a few questions:

* Does this occur every time you select a basemap?

* Does this occur if you refresh the page after the basemap load?

* Could you post the info from https://supportdetails.com/  in this issue or email them to me?

It also also possible this might be related to some of the issues with sprites reported in Seem to be not working with our own vector tile package/layer? So I'll post again when we make progress on that issue

Reply
0 Kudos
ClayDonaldsonSWCA
Occasional Contributor

I was not able to get any of the basemaps to work.Refresh did not fix. Chrome was reporting this error The basemaps were not previewing either:

main.270a8eb….bundle.js:1 ERROR DOMException: Failed to execute 'getImageData' on 'CanvasRenderingContext2D': The canvas has been tainted by cross-origin data.

Operating System

Windows 10 (64-bit)

Screen Resolution

1920 x 1080

Web Browser

Chrome 57.0.2987.11

Web Browser Size

1855 x 990

Color Depth

24 bit

Javascript

Enabled

Macromedia Flash Version

29.0.-1

Cookies

Enabled

Reply
0 Kudos
PatrickArlt1
Occasional Contributor

Clay Donaldson‌ Could you try to load your basemap again? We made some fixes last week that might have resolved this issue.

Reply
0 Kudos
ClayDonaldsonSWCA
Occasional Contributor

Unfortunately, I am still receiving the same error.  

Reply
0 Kudos
PatrickArlt1
Occasional Contributor

Clay Donaldson‌ An option would be to create a group and invite me (username: "patrickarlt7104") so I can take a look if you cannot make the item public. That way I can load it up in the editor and take a look.

Reply
0 Kudos
ClayDonaldsonSWCA
Occasional Contributor

Patrick, the problem occurs with the default basemaps, not a custom one.

Reply
0 Kudos
PatrickArlt1
Occasional Contributor

I have a few more questions then:

1. Does this occur on every browser on your machine? For example Firefox, Edge or Safari?

2. Does this occur for every basemap or just a few? If so which?

3. Can you update your version of Chrome? Chrome 57 is about a year old so that might be a reason for this.

View solution in original post

ClayDonaldsonSWCA
Occasional Contributor

I can confirm switch browsers to Firefox fixed this problem. I am unsure if updating Chrome would achieve the same effect (lacking IT privileges).

Reply
0 Kudos
MichaelVolz
Esteemed Contributor

Clay:

Are you trying to add a default basemap into ArcMap or Pro?  Which version?

Reply
0 Kudos