ArcGIS Pro 2.5: adding subtypes for utility network device feature class ends up with error,

209
2
Jump to solution
04-19-2020 04:07 AM
JamalNUMAN
Esteemed Contributor

ArcGIS Pro 2.5: adding subtypes for utility network device feature class ends up with error,

 

I couldn’t figure out why adding subtypes for utility network device feature class ends up with errors:

 

-The subtype is required by utility networks

-Network topology must be disabled

 

What could be the issue here?

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
1 Solution

Accepted Solutions
MelissaJarman
Esri Contributor

This topic would be a good form of reference for you - Utility network management tasks

The UN has an additive model for domains and subtypes. If you need to make changes to existing subtypes or domains that are being used on the ASSETGROUP and ASSETTYPE fields for network classes you will have to use the Utility Network Package Tools to create asset packages and start fresh with a new UN. 

Utility Network Package Tools | ArcGIS Solutions 

Very similar to this bug as well.

BUG-000115603: When trying to remove a subtype from a feature class.. 

View solution in original post

2 Replies
JamalNUMAN
Esteemed Contributor

It appears that these sorts of errors never end while the documents don’t offer that much of help. For example, I couldn’t manage what to do as I got the error below

 

001987: The domain is required by utility network and cannot be modified

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
MelissaJarman
Esri Contributor

This topic would be a good form of reference for you - Utility network management tasks

The UN has an additive model for domains and subtypes. If you need to make changes to existing subtypes or domains that are being used on the ASSETGROUP and ASSETTYPE fields for network classes you will have to use the Utility Network Package Tools to create asset packages and start fresh with a new UN. 

Utility Network Package Tools | ArcGIS Solutions 

Very similar to this bug as well.

BUG-000115603: When trying to remove a subtype from a feature class.. 

View solution in original post