xls form calculations not working in Survey123 webform during repeats

121
1
12-22-2020 10:49 AM
MarthaRodgers
New Contributor III

Hello community, @IsmaelChivite @JamesTedrick @Philip-Wilson 

Is there a known problem with calculations in Survey123 webform while in a repeat?

It works fine outside the repeat, but once I put it inside the repeat, it's blank. It also works during testing in Connect on my desktop. See below.

Here is the calculation....

concat('Transect_'+ ${TransectNumber_mgmt})

I just want to create a string that says 'Transect_1' so I can pull from the correct CSV form in the next question...and depending on the repeat, of course I would like it to increment.  

The other issue is that the count inside the repeat in the webform isn't working.  Is there a way to know which repeat record you are inside?  I noticed in the upper right corner of each repeat record there is a number...but how to access that?

Thank you!

I'm attaching the zip of the survey as well.

Thank you all!

-Martha

 

 

 

Reply
0 Kudos
1 Reply
IsmaelChivite
Esri Frequent Contributor

Hi Martha.  I got your survey to work. Two suggestions:

  • In your find_transect_name question calculation you should use a comma to separate the different strings you want to concatenate:
    • This is not correct: 'concat('Transect_'+ ${TransectNumber_mgmt})
    • This is correct: 'concat('Transect_', ${TransectNumber_mgmt})
  • To calculate the position of the active repeat record, use the position(..) function into the calculation of the TransectNumber_mgmt question.  The position(..) function is not supported yet in Survey123 Connect or the field app (unless you use the Beta 3.12 version), but it works great in the Survey123 web app (3.11 and newer).

I hope this helps.

Reply
0 Kudos