Why is Survey123 not sorting photos properly by date?

94
1
10-14-2019 05:46 AM
JeffJackson4
New Contributor III

So, just noticed this today when trying to fill out a survey after taking pictures and returning to the office.  But when I go to add photos using the folder option and then try to sort by date and time via the sort function in the upper right of the app, the photos do not appear in any sort of order at all.  In my case, the most recent photo I took shows, followed by several photos from a year ago, then a couple from between four and six months ago, and then my next most recent photo.

Any insight into why this is happening?  Currently using Samsung Galaxy S7 (with most up to date software release).  Also confirmed this is happening on Galaxy S9 (again with most updated software).  Also confirmed this behavior on the Pixel 3.

We take a lot of photos that look very similar, so this makes it very difficult to find the ones we want to use for reporting. Needless to say, this is a major problem for filling out reports.  The pictures are sorted properly in the default photo gallery app on the Galaxys and the Pixel, so this would lead me to believe this is a Survey123 specific issue.  And, one that kind of needs to be fixed.  Or someone to tell me what the heck we are doing wrong?

Reply
0 Kudos
1 Reply
BrandonArmstrong
Esri Regular Contributor

Hi Jeff,

The behavior that you are encountering is a BUG and has been raised in Technical Support as BUG-000125769: The Survey123 for ArcGIS image gallery is unsorted o.. .  The development team has identified the cause, and we hope to have a fix in place shortly. 

We can update this thread once the fix is in place.  

Best Regards,

Brandon

Reply
0 Kudos