Why is my survey telling people their answer is wrong before they even enter it?

71
2
01-30-2019 07:37 AM
Highlighted
Occasional Contributor II

In my survey there is a question asking people to provide an email address, and I have set the constrint field to verify that there is an @ and domain, etc...

https://survey123.arcgis.com/share/12d553750d514467ac83b9fdc63181c1 

but the phrase "dies ist eine ungultige Antwort" (this is an invalid answer) is below the field before the people fill in, and even after when an email is entereed correct. try it and you will see. 

bizarre? There is nothing in my form but the constraint: regex(.,'^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$')

How can I stop my survey from scaring people away with the invalid answer statement?

Reply
0 Kudos
2 Replies
Highlighted
Esri Regular Contributor

Hi Aurelie,

At the moment, this message will display if a value has not been specified in the 'constraint message' column of the XLSForm prior to publishing.

This will change, with the next update of the Survey123 website.  For the meantime, by inputting a value in the 'constraint message' column of the XLSForm for your email question and republishing, you can determine what message is shown instead of “It’s an invalid answer”. I would recommend something like “This must be in the format jsmith@example.com

Hope this helps,

Brandon

Highlighted
Occasional Contributor II

Fantastic - glad to know there is a workaround. Thank you so much.