Why is my date field showing 1589482800000 when people are submitting results from the using the App?

135
4
05-18-2020 10:28 AM
EstellaSmith
New Contributor II

When people submit their surveys, they have the option to chose either a web browser or in the field app.  When data is submitting using the web browser, the date field correctly populated.  However, when users the Survey123 field app the date field shows 1589482800000 instead of the correct date. 

Why would the date field being doing this with the field app?  Would have to do with the fact the date field is set as hidden on the survey form?  I chose to hide the date field because I wanted it to auto-populate and not have the user pick a date.   

Or do I need to unhide my date field and make it a read-only to make sure it populates correctly?

Estella Smith
Reply
0 Kudos
4 Replies
BenTurrell
Occasional Contributor III

Hey Estella Smith‌,

It looks like your date is in epoch time(https://www.epochconverter.com/). Take a look at this link: Decimal date time—Survey123 for ArcGIS | Documentation  It talks about the different limitations for dates and times in the different apps.

Thanks,

Ben


If this answer was helpful please mark it as helpful. If this answer solved your question please mark it as the answer to help others who have the same question.

EstellaSmith
New Contributor II

Thank you.  Now, I know what is showing up and if I need to do a calculation in the future.  For now, I'm going to try setting the Esri field type field to Date and see how that works on the different platforms.

Estella Smith
Reply
0 Kudos
JasonJordan00
Occasional Contributor

You probably need to set the Esri field type as date in the parameters section. Hidden fields default to string, which could be why its showing epoch time.

EstellaSmith
New Contributor II

Thank you.  Setting the Esri field type helped. 

Estella Smith
Reply
0 Kudos