why does my survey crash when trying to take a photo on Windows tablet? It works fine on an iphone.

225
11
02-12-2019 05:14 AM
Highlighted
Occasional Contributor II

I have a Mesa 2 rugged tablet that Survey123 has been downloaded onto.  Everything else in the survey seems to work fine, but when I click on the camera icon to take a picture it crashes the survey.  The same operation works on my iphone though.

Tags (2)
Reply
0 Kudos
11 Replies
Highlighted
MVP

Have you allowed Survey123 access to your camera? 

Under Settings > Privacy > Camera, you will be able to choose specific apps to allow to access the camera. On your iPhone, the app probably prompted you for permission on your first log in.

Reply
0 Kudos
Highlighted
Occasional Contributor II

For some reason, Survey123 doesn't show up as an option when I go to the camera's privacy settings.  

Reply
0 Kudos
Highlighted
MVP

That's strange. I don't have a windows tablet on hand to help, but it shows up in the permissions of my Android tablet and iPhone. Perhaps there's some permission further up the chain that needs to be changed?

Reply
0 Kudos
Highlighted
Occasional Contributor II

Yea, something funky's going on.  I have a feeling it might just be a bug with the app in regards to the windows operating system.  Thanks for taking a look at it for me though, I really appreciate it.

Highlighted
Esri Regular Contributor

Hi Leif,

This issue is specific to the Juniper Mesa 2 and is a defect, as you suspected.  If you do have access to Esri Technical Support, please follow up with them so that they can add your encounter to the existing issue, BUG-000095206.  We will be sure to update this thread when there is movement related to the issue.

Thank you,

Brandon

Reply
0 Kudos
Highlighted
Occasional Contributor II

Thanks for the clarification Brandon, I'll get right on it.

Reply
0 Kudos
Highlighted
New Contributor

has a resolution been found yet . I am still having this issue .

Reply
0 Kudos
Highlighted
New Contributor III

James TedrickJohnathan Hasthorpe

This is happening to us on a Samsung Galaxy S9, app is crashing when the photo is taken. Please let me know if there is a resolution 

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Brita,

Can you please provide more information regarding the crash that you are encountering when taking a photo with your Samsung Galaxy S9?

1. What version of the Survey123 Field App are you using?

2. What version of Android OS does the S9 have?

2.What was the image size in pixels applied in the 'Images' settings for the survey in S123 Connect? 

3. Does this happen with all surveys when attempting to take pictures using the S9 or just one?

4. Can you provide a share link for opening in the field app for one of the surveys exhibiting the behavior?

Thanks,

Brandon

Reply
0 Kudos