Why am I getting "Error: Cannot read property 'layerName' of undefined" when trying to add Feature Report

420
3
02-28-2020 06:38 AM
RobCahalan
New Contributor III

I have published a new survey using Survey123 Connect 3.7.62 and when I try to upload a .docx to the feature report I receive the following error: Error: Cannot read property 'layerName' of undefined

I have used the Survey123 Create Sample Template and I receive the same error on that template.

I have a feeling that a repeat is causing the issue, but even if I exclude the repeat section from the word doc I still get the error. I have tried publishing this report without the repeat section and I was able to use the create sample template and got it to work correctly.

Any help would be greatly appreciated....thanks!

3 Replies
Shwu-jingJeng
Esri Regular Contributor

Hi Rob,

Could you share the xls form so that we can look into this further?

If you would like to share it privately, you could email it to sjeng@esri.com

Thanks,

0 Kudos
KieranSroba
New Contributor II

Hi Shwu-jing, 

Did you find a solution to this? I am running into the same problem. I have attached the spreadsheet that is causing problems below 

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Kieran,

The form has repeats and use pulldata in calculation, to be able to repro the issue, it requires to have all associated resrouces to troubleshoot it. I will recommend you to contact Tech Support to have them setup a repro case in house and troubleshoot it.

Thanks,

0 Kudos