What does "TypeError: e is undefined" in Survey123 mean?

147
5
05-22-2019 11:51 AM
Highlighted
New Contributor II

I have a survey I created then published through Survey123 Connect. When I log onto survey123.arcgis.com and open the published survey, I get the following error even before entering any fields. Wondering if anyone knows what the error is supposed to mean? Attached is a screenshot of the error.

Reply
0 Kudos
5 Replies
Highlighted
Esri Regular Contributor

Hi Bethany,

Can you please upload the XLSForm that you used for the survey to this thread?

Thanks,

Brandon

Reply
0 Kudos
Highlighted
New Contributor II

Brandon, 

Thanks for the follow up. Sure, it is attached. 

Bethany

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Thank you for sharing your from, Bethany.

It looks like the behavior is being caused by a relevant statement and repeat count being applied to the same field (in your case, the field is 'Detailed_Assessment_Household').  We are currently investigating this issue, but in the meantime, a workaround would be to either remove the relevant statement or the repeat count from the field.

Please let us know if you still have issues after attempting to apply this workaround, and we will update this thread after we are able to identify the cause and apply a fix.

Best,

Brandon

Reply
0 Kudos
Highlighted
New Contributor II

Brandon, 

 

Thank you for the prompt response. I checked what you said, and I think it's partially the issue.

 

I have specifically an "and" statement (${Answer_Questions_Willingness} = 'Yes' and ${Number_in_Household} > 0) in the relevant column which I think is what causing the issue. I tested it out by removing the "and" part of the statement (meaning I just had: ${Answer_Questions_Willingness} = 'Yes') and still leaving the statement in the condition in the repeat count column, and did not get an error. 

 

Bethany

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Bethany, yes this make sense.  The issue is related to the same field being used for validation of the repeat_count and relevancy.  In your case, this was 'Number_in_Household'.  Happy that you have a workaround for the time being!

Best,

Brandon

Reply
0 Kudos