Watermark with an image not working

365
5
Jump to solution
03-12-2020 07:27 AM
JimW
by
Occasional Contributor

I am trying to add my company logo as a watermark to an image.  As I understand it, the syntax is

watermark="image=mdclogo.jpg"‍

When I do this, all that appears on my image is the text after "watermark=" and not the actual logo:

This occurs in two different surveys.  It also happened in a survey I created using the samples.  I tried both PNG and JPG with the same results.

Am I missing something or doing something wrong?  Thanks.

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
ChelseaRozek
MVP Regular Contributor

Okay, I ran through it myself and see what you're saying.

Try it like this:

watermark= &image=logo.png

*note the space and & before image

I also found it helpful to use imageSize: watermark= &image=logo.png&imageSize=80

The documentation, posts on GeoNet, etc. seem to be out of sync, maybe the syntax has changed with versions? Anyways, I set up the Watermarks sample in Connect and that's how I found that this syntax works. They put esri&, but then you get "esri" printed on the image as well, so I changed it to just " ".

View solution in original post

5 Replies
ChelseaRozek
MVP Regular Contributor

try without the quotes. the documentation (Watermarks—Survey123 for ArcGIS | Documentation) just shows: watermark=image=example.png

Can you confirm that the image is also in your survey's media folder?

0 Kudos
JimW
by
Occasional Contributor

I've tried with quotes and without quotes and only get the text and not the actual image.  I have confirmed that the images are in the survey's media folder.

0 Kudos
ChelseaRozek
MVP Regular Contributor

Okay, I ran through it myself and see what you're saying.

Try it like this:

watermark= &image=logo.png

*note the space and & before image

I also found it helpful to use imageSize: watermark= &image=logo.png&imageSize=80

The documentation, posts on GeoNet, etc. seem to be out of sync, maybe the syntax has changed with versions? Anyways, I set up the Watermarks sample in Connect and that's how I found that this syntax works. They put esri&, but then you get "esri" printed on the image as well, so I changed it to just " ".

JimW
by
Occasional Contributor

The ampersand (&) before the image parameter did the trick

bottomLeftWatermark=&image=mdclogo.jpg&imageSize=150‍

In my case, if I included a space, just the text appeared where the image should be.

Definitely a disconnect between the help documentation and what works, at least in my case.  Here is how the online help says to configure the image parameters.  No ampersand before the image parameter.

watermark=image=example.png&imageSize=50

Thanks for your help!

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Jim,

Thanks for reporting this, we will update the documentation with the correct sytaxto include the ampersand (&) before the image parameter.