Viewing Survey123 form on Web-Pale blue "wrapper"?

2211
29
Jump to solution
07-31-2018 01:05 PM
neiden
by
New Contributor III

I just published a survey from ArcGIS Connect that will be accessed by the public via a web form. In connect, I matched my survey to my agency's style guide (background color, text color, etc.) and was happy with the results. However, the survey is "wrapped" in a pale blue color...how can I fix this? It's important that this be branded according to agency guidelines and be more seamless to our public.

Just spent the last hour exploring every setting, etc. to no avail...where is this pale blue background coming from and how can it be changed? Anyone else run into this??

Thanks!

Nikki  

Tags (1)
29 Replies
All_UsersWCSRT
New Contributor

Has this changed again with the most recent update? I tried using the workaround but it just resets to the default colour theme. I've made sure the previewer is closed and that the file has saved before re-publishing.

Thanks

Reply
0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Liam,

Yes, the syntax has changed slightly to support associating multiple themes to a form - I've updated my response above.

Reply
0 Kudos
Anneka_France
Occasional Contributor II

What does multiple themes mean? Can you create multiple web forms with different themes from the same survey?

Anneka France
GIS Analyst at The Rivers Trust
Reply
0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Anneka,

As the Survey123 website has improved the capabilities to set custom themes, the need to store multiple themes (one imported from another survey, the organization's theme, and a custom theme) has become apparent.  Currently we don't support selecting a theme, but are considering that as a possible enhancement.

All_UsersWCSRT
New Contributor

Hi James,

That would be a great enhancement and a real time saver! Would be great to see that in a future release.

Reply
0 Kudos
kmsmikrud
Occasional Contributor III

Hi there,

I was just following the code update from April 2019 but having the issue of the text not staying in the .info file after republishing. I wanted to check to see if the code might have changed again with any updates for modifying the green default background color?

Thanks!,

Kathy

Reply
0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Kathy,

The steps in this thread are no longer necessary - you can set the page background using the web designer for Survey123 Connect-published surveys.  

That being said, the most likely reason the text is not staying is that you are previewing the form with Survey123 Connect - the text needs to be altered while Survey123 Connect is not using the form you are editing.

Reply
0 Kudos
LarsArneson
New Contributor II

Is this still the current solution? I've tried inserting the provided text into the .info file without any changes. Thanks

Reply
0 Kudos
CarolAnnWilliams
New Contributor

Go to the online survey123 manager and change the style options, it's towards the bottom of the appearance menu.

RyanKey2
New Contributor

Still does not correct surveys created and published from Survey 123 Connect 3.11

Reply
0 Kudos