Uploading Multiple Files is not Working When Survey123 Form is Opened in Browser

285
2
11-29-2020 03:20 AM
majdi_turkman
New Contributor II

Hello,

I've created a Survey123 form using the ArcGIS Survey123 Connect. One section of the form should enable users to upload multiple files. I've used to file question type with multiline appearance.

connect.png

If I open the form using the mobile app, everything seems to be working fine.

IMG_4765.PNG.jpg

But when I use the web browser option, I can upload a single file only.

webform.png

 

This survey is published to ArcGIS Enterprise 10.8.1

Appreciate any help or directions in this regards!

Thanks,

Majdi

Reply
0 Kudos
2 Replies
BrettStokes
Esri Contributor

Hi Majdi,

What version of Connect are you using to publish your survey? By default, version locking is enabled for your surveys. This means that surveys are rendered using same version of the web app as was used to publish the survey in the first place. Eg a survey published in Connect 3.9 will be rendered using the 3.9 version of the web app.

The file question type supports the 'multiline' appearance from 3.10 onwards. If you're using an older version of Connect (eg 3.9 or earlier) you will need to change the survey settings so that it always uses the latest version of the web app to render your survey. This setting is found in the 'Settings' tab:

BrettStokes_0-1606801544355.png

Hope this helps,

Brett

Reply
0 Kudos
majdi_turkman
New Contributor II

Hi @BrettStokes,

Thanks for your reply!

I already set my survey to always use the latest version, but still have the same issue.

Screenshot 2020-12-01 151327.jpg

 

Any thoughts!

Reply
0 Kudos