Updating Geopoint when copying to a new survey from Inbox

153
1
09-24-2020 08:16 AM
KevinLambeth1
New Contributor III

We are trying to set up a workflow using the inbox in survey123 where a user is assigned a task (based a previously submitted feature) in the inbox and then copies the data to a new survey to capture new data as a new feature.  The workflow has been coming together nicely, but we ran into an issue where the geopoint won't update to the device's current location even when we cycle the relevancy for the question.  We keep the geopoint question read-only since field workers have been known to misplace the location since they are offline during collection which causes issues further down the line and want to rely on GPS reported location alone.

Is there any workaround or suggestions to allow a new location to be captured using this method?

Also, we have looked at creating a copy of the assignment and allowing users to edit the information directly, but since photos are required for the update, only the copy to a new survey workflow will work for this instance.

0 Kudos
1 Reply
Philip-Wilson
Esri Frequent Contributor

Hi Kevin,

Are you able to provide a copy of the xslx file so we can take a closer look? This may help understand the questions and layout of the survey and how it works.

Is the geopoint question always read only? Is it set via a static "yes" value, or do you use an expression?

If you make the question not-relevant and then back to relevant, provided it is not read only, the geopoint should be able to get the updated location. Depending on how your survey is configured, and the timing of changes to expressions and relevance etc, the user may need to select the re-calculation button next to the geopoint question.

Regards,

Phil.

0 Kudos