Updated Survey123 now I can't Republish my Surveys

157
2
Jump to solution
04-25-2018 12:31 PM
Highlighted
New Contributor III

I updated my Survey123 Connect software last week and now I can't republish the survey without being prompted that the service is not compatible.  Anyone have a work around?  The table structure is def. the same.  The survey was published months ago with an older version of the software (likely pre 2.0).  I was hesitant to upgrade because of this very issue!  Any assistance is appreciated.

Thanks,

Dan

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Esteemed Contributor

Hi Daniel,

There have been a number of changes between the previous version you are using and current Survey123.  Given the message you are seeing, it is most likely that the form_id value is mismatched to teh layer name of your feature service (See Settings—Survey123 for ArcGIS | ArcGIS ).  Aside from hat, you may see advisories to create fields for note questions in your survey; in order to avoid that, you can either remove teh name values for notes or set their esriFieldType to null.

View solution in original post

Reply
0 Kudos
2 Replies
Highlighted
Esri Esteemed Contributor

Hi Daniel,

There have been a number of changes between the previous version you are using and current Survey123.  Given the message you are seeing, it is most likely that the form_id value is mismatched to teh layer name of your feature service (See Settings—Survey123 for ArcGIS | ArcGIS ).  Aside from hat, you may see advisories to create fields for note questions in your survey; in order to avoid that, you can either remove teh name values for notes or set their esriFieldType to null.

View solution in original post

Reply
0 Kudos
Highlighted
New Contributor III

James,

Thank you for the prompt reply.  That worked.  While I had the Form_ID previously populated with spaces in it between words (e.g. Buckeye Lake GeoTech Production).  The FS layer name contains underscores instead of spaces (e.g.  Buckeye_Lake_GeoTech_Production)  Updating the Form_ID to include the underscores resolved the problem.

Thank you,

Dan

Reply
0 Kudos