Updated Survey visible to creator but not users in the group survey is shared with

132
3
08-07-2018 07:35 AM
EdwardGlover1
New Contributor III

I had to republish a Survey due to the need for an additional question.  It republished successfully and users have been able to download the new survey (called the same name) and use it for collection.  However, only I can see the new survey when logging into Survey123.com - the users see only the old one.  I've attached screen grabs depicting this:  The new survey has 102 records, the old survey has 922 records.  I've also attached a screengrab from AGOL.  I renamed the old feature layer and unshared it.  The stakeholder feature layer contains the old data.  Why can't the users see the new survey in Survey123.com?

Reply
0 Kudos
3 Replies
EmilyCaruccio
New Contributor III

Hi! I've had this same issue. Here is how I solved the problem:

The user must open the Survey123 for ArcGIS app. Click the associated survey (old survey). Select the three lines at the top right hand corner. Then click Delete Survey.

The old survey is cached and it must be removed before the app will read the new one. 

Reply
0 Kudos
CarlHolt1
Occasional Contributor III

This will solve the issue with the user seeing the submitted surveys in Survey123.com and will not lose submitted surveys in the app?

Reply
0 Kudos
EdwardGlover1
New Contributor III

Thanks for your reply.  I was able to do what you suggested within the Survey123 app on their mobile device.  My issue is when they log into Survey123 on a computer to view survey data -  the old survey is still appearing.  I think it has something to do stakeholder view in AGOL, but don't know how Survey123 interacts with it.  For some reason the feature layer updated but not the view.