THE EXISTING FEATURE SERVICE IS NOT COMPATIBLE WITH THE SURVEY

1299
11
Jump to solution
08-24-2021 07:12 PM
Billy
by
Occasional Contributor

Hi,

Version: Survey123 Connect 3.12.232

We are trying to extract the latitude and longitude from a geopoint question of published survey. We followed the recommendations of this blog, from 2016: https://community.esri.com/t5/arcgis-survey123-blog/pulling-data-from-geopoint-questions/ba-p/896838. We tried using the hidden question type with pulldata to extract the x\y, and using decimal question type, pulldata and hidden appearance; in both cases we are getting the message that "The existing feature service is not compatible with the survey".

 

The survey was created in 2020, and the blog is from 2016. Why the addition of these questions is raising this warning? That we understand means that if we publish the survey a new service will be create and the old data will be lost.

Billy_0-1629857410207.png

 

 

 

0 Kudos
2 Solutions

Accepted Solutions
jcarlson
MVP Notable Contributor

Just go to the feature layer and add the fields using the name and type from your XLS form. Then when publishing the survey, it will recognize the existence of those fields and not prompt for re-publishing the service.

- Josh Carlson
Kendall County GIS

View solution in original post

jcarlson
MVP Notable Contributor

If all fields are present and no schema changes need to be made to the underlying service, you see this:

The survey will be updated without affecting the existing data.
- Josh Carlson
Kendall County GIS

View solution in original post

0 Kudos
11 Replies
jcarlson
MVP Notable Contributor

Just go to the feature layer and add the fields using the name and type from your XLS form. Then when publishing the survey, it will recognize the existence of those fields and not prompt for re-publishing the service.

- Josh Carlson
Kendall County GIS
DougBrowning
MVP Notable Contributor

Josh is correct it is telling you the fields are not there but you can add them using AGOL.

Also if you just need to display the lat/long I use Arcade for this.  That way if the point is ever moved it will auto update vs the static fields.

Code is

Convert a Web Mecator Lat/Long to a WGS84 Lat Long using Arcade in a web map pop up

var originShift = 2.0 * PI * 6378137.0 / 2.0;
var lon = (Geometry($feature).x / originShift) * 180.0;
var lat = (Geometry($feature).y / originShift) * 180.0;
lat = 180.0 / PI * (2.0 * Atan( Exp( lat * PI / 180.0)) - PI / 2.0);
return [lon, lat];

Or as text for passing to apps
var originShift = 2.0 * PI * 6378137.0 / 2.0;
var lon = (Geometry($feature).x / originShift) * 180.0;
var lat = (Geometry($feature).y / originShift) * 180.0;
lat = 180.0 / PI * (2.0 * Atan( Exp( lat * PI / 180.0)) - PI / 2.0);
return lon + " " + lat;
0 Kudos
Billy
by
Occasional Contributor

Hi Josh\Doug,

Thanks for your answers. We need the lat\lon as separate fields in the database because we need it for another system when we export the data as csv.

Regarding the addition of the fields, Survey123 is offering to add the additional fields to the feature service during the re-publishing (see the publishing dialog image). Our concern is that we have added new fields in the past and never received the warning "The existing feature service is not compatible with the survey". Our understanding is that this warning means that if we re-publish the survey with the changes then a new feature service will be created and the old data will be lost.

0 Kudos
jcarlson
MVP Notable Contributor

You need to add the fields from the AGOL Content page, not via S123.

jcarlson_0-1629919014197.png

I don't know if that message and overwrite option is a new addition, but I have only seen it when adding fields to the original form in Survey123 Connect.

When adding new fields to additional forms that were created using the "from existing feature service" option, I get a different error that my form cannot be published due to fields not being in the feature service.

- Josh Carlson
Kendall County GIS
Billy
by
Occasional Contributor

Before adding the fields in AGOL we need to be sure that when we try to re-publish the survey the old data won't be erased.

I searched the documentation for a reference to the warning message but didn't find anything.

0 Kudos
jcarlson
MVP Notable Contributor

If all fields are present and no schema changes need to be made to the underlying service, you see this:

The survey will be updated without affecting the existing data.
- Josh Carlson
Kendall County GIS
0 Kudos
Billy
by
Occasional Contributor

Ok, I will try it and report back the result.

Thanks.

0 Kudos
Billy
by
Occasional Contributor

I added the fields to the feature layer in AGOL like you recommended and re-published the survey. It worked fine without data loss.

Thanks.

anonymous
Occasional Contributor

@Billy Could you give summary of your steps?
is going to be good documentation here for future  
Thanks

0 Kudos