Survey123 Webform TypeError: Cannot read property 'require' of undefined

775
7
04-13-2020 06:18 AM
DaronNichols
New Contributor

Survey 123 form is attached. Was created in Survey123 Connect Ver 3.7. This survey was working several weeks ago but now when trying to open the webform I get the error :

Error: Initializing form...

  • TypeError: Cannot read property 'require' of undefined

I feel like this may have to do with a recent update, but I'm not sure what changed and how to fix it.

Tags (1)
0 Kudos
7 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Daron,

I can see the behavior you describe with your form.  In troubleshooting it, it appears the issue has to do with the read-only geoshape question- making that not read-only resolves the issue.  As you mentioned, this was working correctly in a previous version - turning on version locking will resolve the issue, if you are able to.

KevinThompson1
New Contributor III

Hello James,

I am having this issue currently.

Was this bug logged to be look into further? I just upgraded to Survey123 Connect 3.9.120 and am getting this issue on my survey, which has a Geoshape question. It seems that something evening as simple as the image below causes this error.

Thank you and have a nice weekend!

KevinThompson1
New Contributor III

After further testing this seems to occur also on Geotrace questions, but not to Geopoint questions.

0 Kudos
RyanNosek1
Esri Contributor

I've been able to reproduce this behavior with a Geotrace question as well. James Tedrick any insight into which version of Survey123 Connect this works in, and any update if the bug will be addressed in the next release?

Jen_Zumbado-Hannibal
New Contributor III

UPDATE: I cleared my browser and it still won't work. 

I'm having the same issue but my says 'Cannot read property 'replace' of undefined'. I used 3.11 Survey123 Connect. The only difference is I have a geopoint. However, in the .xlsx I don't have it as a ready only (readonly is blank). 

So, what else could be causing the issue? @JamesTedrick  or @JodyZhengLiu 

0 Kudos
JodyZhengLiu
Esri Contributor

Hi all,

Thanks a lot for the feedback. This is fixed on survey123.arcgis.com.

Thank you,

Jody Zheng Liu

KevinThompson1
New Contributor III

Thank you so much Jody!!! Works perfectly again

0 Kudos