Survey123 version 3.0.134 on Android 7 text field issue

143
3
08-08-2018 08:30 AM
SusannaSaari
New Contributor II

Hi all,

We're having problems with the latest version of the app (3.0.134) on our Android 7 (Huawei T3 10, AGS-W09) tablets.

Basically, our field surveyors report that with "free text" fields, when you hit return, the last typed word is deleted, and when adding text amongst previously typed text - the entire text field is "scrambled" (funny characters/rearranged characters/etc).

I should mention that this does not happen on the same version of Survey123 app (3.0.134) on our iPads.

Has anyone else experienced this, please? Any suggested solutions, please?

Many thanks.

Reply
0 Kudos
3 Replies
BrandonArmstrong
Esri Regular Contributor

Hi Susanna,

Sounds like interesting behavior.  If possible, can you please try to reproduce the issue on any other Android phones/tablets that you have and let us know your results?

Also, if possible, it would be helpful to have a copy of the XLSForm that was used to create the survey along with reference to the exact question where the behavior is encountered.  I will send you a message in GeoNet so that you can send this over.

Thanks,

Brandon

Reply
0 Kudos
SusannaSaari
New Contributor II

Following some further investigation - it would appear that the issue is linked to which keyboard input is selected. The issue manifests on the Huawei tablets only with “SwiftKey Keyboard”. When using the standard Google keyboard, there were no issues with text field entries.

BrandonArmstrong
Esri Regular Contributor

Thank you for sharing your findings, Susanna. 

In further testing, it appears that the behavior occurs on several Android devices when using the SwiftKey Keyboard for entry of multiline text questions.  I have gone ahead and made note of the issue in our internal backlog.

 Best,

Brandon

Reply
0 Kudos