Survey123 submission "Getting service information" stuck reading related table

1640
21
04-18-2018 07:30 PM
GeospatialManagement
New Contributor

I have a featureclass (checkpoints) which has its geometry defined in Workforce, and is populated using Survey123. The featureclass also has a related table that will use Survey123 to populated records (log of vehicles at checkpoints). 

When I try to submit a completed survey, either on the featureclass or related record I encounter an issue when "Getting service information" on the related record, which halts progress.

Is this a known issue, and does it have a fix?

Thank you.

Reply
0 Kudos
21 Replies
JamesTedrick
Esri Esteemed Contributor

Hi,

It sounds as if an error is occuring that is not being cleared correctly.  Can I ask that you log an attempt to submit data (see Troubleshoot—Survey123 for ArcGIS | ArcGIS  to get started; instead of waiting for a console to appear, start logging to a file by clicking the switch).  This is most easily done on the Desktop; the log file will be at C:\Users\<username>\ArcGIS\AppStudio\logs

Reply
0 Kudos
GeospatialManagement
New Contributor

Hi James,
Thank you for the quick response.

I have generated a log. What is my next step, not sure what to look out for within the log?

Reply
0 Kudos
JasonFrancis
New Contributor

Hi James,

I am fighting with this error since last Tue and still not figured it out. I created a survey using existing feature service with two feature layers and two related tables. I have stripped the item down to minimum, re-published service a number of time, called tech support and still have no idea what I did wrong. Thanks to you reply on this topic, I have generated the log file and "might" identified the possible error : "TypeError: Cannot read property 'name' of undefined". However, how to fix it?!

I attached the log file here and could you take a look of the log and let me know what should I do next?

 

(for some reason, this reply from my client Jason although I logged in with my account.)

Thanks,

 

Ming

MarkBennett
New Contributor III

My problem is resolved. There probably is something goofy in the MXD file that I used to publish the feature service. I imported the mdx to Pro and it faired to publish the same data (Staging Error). Then, I Started a new Pro project and add the data from scratch. It worked both for publishing and submit the survey. 

Sometime, it just easier to re-start instead of fighting the issue! 

Ming

Reply
0 Kudos
SeanLavallee__MES_
New Contributor II

Good Afternoon, I am having issues with my survey submissions being sent. The survey just spins and never sends with "Getting Service Items - GDB_ServiceItems. I tried recreating the survey and going through permissions but nothing is different permissions wise from my survey that work and the ones that do not. I've added the log to try and diagnose the issue but I do not see anything sticking out at me.This seemed to have happened overnight because the surveys were sending. I've contacted our information technology department to verify it is not the Bug000103217 I've researched about, but I do not know when they will ever get back and data collection projects have a deadline.

<15>1 2019-01-09T17:24:12Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="signOut" filename="Portal.qml" line="187"] qml: signOut
<15>1 2019-01-09T17:24:12Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="writeSettings" filename="Portal.qml" line="896"] qml: Write portal settings: ArcGIS Online url: https://www.arcgis.com isPortal: false ignoreSslErrors: false supportsOAuth: true redirectUri: urn:ietf:wg:oauth:2.0:oob externalUserAgent: false networkAuthentication: false singleSignOn: false
<15>1 2019-01-09T17:24:12Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="updateRedirectUri" filename="Portal.qml" line="1161"] qml: updateRedirectUri: urn:ietf:wg:oauth:2.0:oob
<15>1 2019-01-09T17:24:12Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="updateRedirectUri" filename="Portal.qml" line="1162"] qml: appName: Survey123ConnectforArcGIS installName: Survey123ConnectforArcGIS standalone: true singleInstance: true appRedirect: arcgis-survey123connect://localhost/oauth2/approval true
<15>1 2019-01-09T17:24:23Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="default"] bool __thiscall AbstractSocket::bind(const class QJSValue &,unsigned short,enum AbstractSocket::BindMode) "239.255.255.250" 1900
<15>1 2019-01-09T17:24:23Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="onStateChanged" filename="SSDPListener.qml" line="84"] qml: SSDPListener status: 4
<15>1 2019-01-09T17:24:25Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="expression for onStateChanged" filename="Portal.qml" line="214"] qml: Application state changed: 2
<15>1 2019-01-09T17:24:25Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="expression for onStateChanged" filename="Portal.qml" line="214"] qml: Application state changed: 2

Much Appreciated!

Reply
0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Sean,

The portion of the log file you attached does not have any errors (<15> in the log file indicates an informational comment).  Can you provide a copy of the entire file?

Reply
0 Kudos
SeanLavallee__MES_
New Contributor II

Looking for the attach file...apologies. Don't see in in the reply.

<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Logging started: 2019-01-09T18:00:58
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Application Name: Survey123ConnectforArcGIS
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Application Version: 3.1.126
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Application File Path: C:/Users/SLAVALLEE/Applications/ArcGIS/Survey123ConnectforArcGIS/Survey123ConnectforArcGIS.exe
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Application Directory Path: C:/Users/SLAVALLEE/Applications/ArcGIS/Survey123ConnectforArcGIS
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ AppFramework Version: 3.1.113
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Qt Version: 5.10.0
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Operating System: Windows 7 SP 1 (6.1)
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Operating System Type: windows
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Operating System Version: 7sp1
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Kernel Type: winnt
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Kernel Version: 6.1.7601
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Build ABI: i386-little_endian-ilp32
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Current CPU Architecture: x86_64
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Build CPU Architecture: i386
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ SSL Library Version: OpenSSL 1.0.2o 27 Mar 2018
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Host name: CND7222VX4
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Domain name: hq.menv.com
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Default locale: en_US
<14>1 2019-01-09T23:00:58Z CND7222VX4 Survey123ConnectforArcGIS 9776 - - $ Release Type: store
<15>1 2019-01-09T23:01:16Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="expression for onStateChanged" filename="Portal.qml" line="214"] qml: Application state changed: 2
<15>1 2019-01-09T23:01:16Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="expression for onStateChanged" filename="Portal.qml" line="214"] qml: Application state changed: 2
<15>1 2019-01-09T23:02:00Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="expression for onStateChanged" filename="Portal.qml" line="214"] qml: Application state changed: 4
<15>1 2019-01-09T23:02:00Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="reset" filename="Portal.qml" line="620"] qml: Token expiry timer not restarted
<15>1 2019-01-09T23:02:00Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="expression for onStateChanged" filename="Portal.qml" line="214"] qml: Application state changed: 4
<15>1 2019-01-09T23:02:00Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="reset" filename="Portal.qml" line="620"] qml: Token expiry timer not restarted
<15>1 2019-01-09T23:02:04Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="write" filename="Config.qml" line="92"] qml: Saving Configuration
<15>1 2019-01-09T23:02:04Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="log" filename="Config.qml" line="109"] qml: Configuration -
<15>1 2019-01-09T23:02:04Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="log" filename="Config.qml" line="111"] qml: * fontFamily: Avenir Next LT Pro
<15>1 2019-01-09T23:02:04Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="log" filename="Config.qml" line="112"] qml: * textScaleFactor: 1
<15>1 2019-01-09T23:02:04Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="log" filename="Config.qml" line="113"] qml: * apiUrl: https://survey123.arcgis.com/api
<15>1 2019-01-09T23:02:04Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="log" filename="Config.qml" line="114"] qml: * ignoreSslErrors: false
<15>1 2019-01-09T23:02:04Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="write" filename="Config.qml" line="99"] qml: apiUrl https://survey123.arcgis.com/api
<15>1 2019-01-09T23:02:04Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="write" filename="Config.qml" line="100"] qml: ignoreSslErrors false
<15>1 2019-01-09T23:02:11Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="read" filename="PortalsList.qml" line="68"] qml: Empty portal list: SyntaxError: JSON.parse: Parse error
<15>1 2019-01-09T23:02:11Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="setPortal" filename="Portal.qml" line="1133"] qml: setPortal: {
"objectName": "",
"externalUserAgent": false,
"ignoreSslErrors": false,
"isPortal": false,
"name": "ArcGIS Online",
"networkAuthentication": false,
"singleSignOn": false,
"supportsOAuth": true,
"url": "https://www.arcgis.com"
}
<15>1 2019-01-09T23:02:11Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="signOut" filename="Portal.qml" line="187"] qml: signOut
<15>1 2019-01-09T23:02:11Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="writeSettings" filename="Portal.qml" line="896"] qml: Write portal settings: ArcGIS Online url: https://www.arcgis.com isPortal: false ignoreSslErrors: false supportsOAuth: true redirectUri: urn:ietf:wg:oauth:2.0:oob externalUserAgent: false networkAuthentication: false singleSignOn: false
<15>1 2019-01-09T23:02:11Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="updateRedirectUri" filename="Portal.qml" line="1161"] qml: updateRedirectUri: urn:ietf:wg:oauth:2.0:oob
<15>1 2019-01-09T23:02:11Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="updateRedirectUri" filename="Portal.qml" line="1162"] qml: appName: Survey123ConnectforArcGIS installName: Survey123ConnectforArcGIS standalone: true singleInstance: true appRedirect: arcgis-survey123connect://localhost/oauth2/approval true
<15>1 2019-01-09T23:02:12Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="default"] bool __thiscall AbstractSocket::bind(const class QJSValue &,unsigned short,enum AbstractSocket::BindMode) "239.255.255.250" 1900
<15>1 2019-01-09T23:02:12Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="onStateChanged" filename="SSDPListener.qml" line="84"] qml: SSDPListener status: 4
<15>1 2019-01-09T23:02:13Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="expression for onStateChanged" filename="Portal.qml" line="214"] qml: Application state changed: 2
<15>1 2019-01-09T23:02:13Z CND7222VX4 Survey123ConnectforArcGIS 9776 - [AppStudio@11205 category="qml" function="expression for onStateChanged" filename="Portal.qml" line="214"] qml: Application state changed: 2

Reply
0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Sean,

This looks like a log file that has just been initialized.  To confirm, you are starting the log, then attempting to submit (getting hung in the middle of submission) and then retrieving the log file?

Reply
0 Kudos
SeanLavallee__MES_
New Contributor II

Here is the latest log file.

-Sean

Reply
0 Kudos