Survey123 ROW Permit Submit request Error - Upload capability is not supported for this service ?

386
9
11-14-2018 02:59 AM
Occasional Contributor

Hi,

I have deployed ROW permit survey application using ArcGIS Pro automated deploy solution as instructed here Configure solution - ROW Permit | ArcGIS Solutions for Local Government.

ROW Permit deployed successfully and I can see in my Portal for ArcGIS 10.6.1

Now, I open Survey123 for ArcGIS in my system,submitted the very first ROW Permit request and I got the below error.

"Upload Capability is not supported for this service"

Thanks,

Reply
0 Kudos
9 Replies
Esri Regular Contributor

Hi Mayur


We have replicated this issue and are working on a resolution. We will update this issue when we have more information.

Thanks

John

Reply
0 Kudos
New Contributor II

Has there been a fix for this issue? We are working to create a survey123 form and I am getting the same error. We have never had this issue before. 

Reply
0 Kudos
Esri Regular Contributor

Hi Matt - this issue is currently being worked on. But unfortunately won't be resolved in time for the 3.2 release.

Reply
0 Kudos
New Contributor II

Jonathan,

Can you confirm if this is an issue related to Survey123 or Portal/Enterprise.

We are currently running Portal version 10.6, and this issue didn’t present itself to us until we installed “The Portal for ArcGIS Privilege Escalation Security Patch is available for versions 10.6, 10.5, 10.4, and 10.3 and includes a fix for this issue” in December. Until then we had used Survey123 without issue.

Please confirm.

Matt

Reply
0 Kudos
Esri Regular Contributor

Hi Matt

The issue looks to be related to the portal privilege patch and only effects 10.6.

We will keep you up to date on developments.

Thanks

John

Reply
0 Kudos
Esri Regular Contributor

These issue seems to occur when the service editor setting 'What kind of editing is allowed?' is set to 'Add features'. If you set it to 'Add and update features' it adds the Uploads capability and you can successfully submit the survey with attachments. I have updated this on the ROW Permit solution and if you re-deploy the Solution you will get this setting and it should work in Portal.

Reply
0 Kudos
New Contributor II

Chris, 

We have those setting enabled and we have uninstalled the portal privilege patch referenced above which has not fixed the issue. As I previously stated we had multiple surveys which worked without issue that now do not work. 

Reply
0 Kudos
New Contributor II

Hi Chris, 

This is (also) not working in the Community Events solution. I am using Survey123 Connect to modify a form created from the Community Event feature layer. 

However, if I try to add a file or image field and add data to it, I receive the following error: "Uploads Capability is not supported for this service - cannot add attachment". 

I have attachments enabled in the Community Events Layer and in settings, Add, update, and delete features is enabled.

Update!

As mentioned in this post, sync for the Feature Layer must be enabled in settings and then I can upload.

Enable Sync under Settings/Editing

Reply
0 Kudos
Esri Contributor

Hi Mayur,

 

Please have a look at the following post which contains a similar issue with a workaround for you to try:

 

https://community.esri.com/message/849937-re-cannot-upload-attachments?commentID=849937#comment-8499...

 

Let me know if you have success.

 

Thanks,

 

Brett

Reply
0 Kudos