Survey123 related table not storing parent Global ID, cannot save repeats

209
1
03-24-2021 06:06 AM
BertKraan1
Occasional Contributor III

Starting with a 'flat' feature layer I have created a feature layer with a related table

I'm using the Global ID from the feature layer as the foreignkey in the table. This works, rows in the layer have between 0 and 3 rows in the related table as expected.

Then I created a survey using 'connect' and 'feature service' as input which created a survey with a repeat section.

Existing data seems to be alright, however I cannot add another record/repeat when there is existing data (I tried allowAdds=true in bind::esri:parameters  although this should be default, either way doesn't work)

Another disturbing  thing is when I create a new survey and fill in the repeat, this gets saved (I can see it in online) but the repeating section does not have the globalID in the 'foreignkey field so the connection is lost.

What am I doing wrong here? How do I get the globalID of the parent in the repeat/related record?

 

thanks in advance for your time.

 

Bert

0 Kudos
1 Reply
DougBrowning
MVP Frequent Contributor

What did you call the foreign key field?  123 is expecting parentglobalid.

I usually have my own relationship class as well that has my own created key vs globalid.  I then pass that into each repeat.  This then works even on exports and and imports.

Hope that helps.

Big writeup here  https://community.esri.com/t5/arcgis-survey123-questions/mapping-with-survey123-within-a-polygon-or-... 

0 Kudos