Survey123 PullData function working in Browser, but in not Mobile App

631
13
07-11-2018 03:49 AM
Highlighted
Occasional Contributor

I have a survey123 form published that's using the pulldata function to select data from a .csv file and calculate the value/fill-in a few fields based on the results of a select one field. The survey works as expected when accessing the survey from a browser, but the pulldata function does not work on a mobile device (I have tested on Windows 10 and iOS).

Has anyone seen this before, I'm surprised this would work in a browser, but not in the survey123 mobile application.

13 Replies
Highlighted
Esri Frequent Contributor

Hi Brian,

Can you please provide a copy of the xlsx file you are using for your survey so we can take a closer look.

Phil.

Reply
0 Kudos
Highlighted
Occasional Contributor

Can you send me your email address so i can send the file via email?


Brian

Reply
0 Kudos
Highlighted
Occasional Contributor

my email is behiller@burnsmcd.com, please send me your email and I'll pass along the .xlsx file.

Brian

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Thanks, have just sent you an email.

Reply
0 Kudos
Highlighted
New Contributor

Hi Brian/Philip,

I also have the same problem using the Survey123 app.

Kim.

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Hi Kim,

See my reply to Brian in this thread. Do you have commas in the data in your external CSV file being used for pulldata(), if so you need to remove them.

Phil.

Reply
0 Kudos
Highlighted
New Contributor

Hi Phil,

No I don't have any commas in my csv.  If I open the file in a text editor, the commas only exists as column separators. Did you receive my csv/excel file from Ben?

Kim.

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

No, I don't have a copy of your external csv file, can you please send to me? Do you have any other special characters in the csv?

Reply
0 Kudos
Highlighted
New Contributor

Hi,

Can I have your email address so I can email you the file?  Sorry I thought I did, but checked my sent queue and did not have an email address for you.

thanks,

Kim.

Reply
0 Kudos