Survey123 Publishing Not Working Properly

303
5
07-23-2018 05:43 AM
JohnSmith40
New Contributor III

I’ve been using a Survey123 app since last year to collect data from our inspectors. Each month I need to update the projects on the app (data stored in a CSV in the media file). It has worked great until this month. For a reason that is escaping me, the projects are not updating on the app when I publish the survey. However, these projects are showing correctly in the preview of the survey available on the Survey123 Connect desktop application.

Anyone have an idea why this might be occurring?

Any help is greatly appreciated.

0 Kudos
5 Replies
Philip-Wilson
Esri Frequent Contributor

Hi John,

I assume after the updates are made to the csv file, you are re publishing the survey and then getting the users to download the updated surveys on their devices? What version of Connect and the App are you using, and on what devices and OS versions?

Are you able to provide a copy of the xlsx form and also any csv files used in the media folder. This may help us to investigate the issue further.

Phil.

0 Kudos
JohnSmith40
New Contributor III

Hello Philip,

 

That is correct. I update both the CSV and the “choices” tab in the XLSX form and then publish the updated survey for the inspectors to download on their devices. I am using Connect version 2.7.72 and Survey123 App version 2.8.2. We are using iPhones with the latest iOS version (11.4.1).

 

I forgot to mention: I unchecked “Export Data (Allow others to export to different formats)” in the “Settings” of the feature layer. It was after this action that I noticed the publishing changes not coming through to the app. Even after rechecking this option the survey is still not working properly though.

 

I have a work around but it’s not ideal since I lose all the tracking data about who submitted each survey on specific dates. If I use the option “create a new survey” on the current survey in Connect, the new survey will have all the new projects. However, I would prefer to have the current survey working again and not use this work around.

 

If this information doesn’t help you, I’ll ask my supervisor if I am able to provide you with the CSV and XLSX form.

 

Thank you for your help.

0 Kudos
Philip-Wilson
Esri Frequent Contributor

Hi John,

The “Export Data (Allow others to export to different formats)” in the “Settings” has nothing to do with the choice lists and external csv files in media folder being available in the app. This option is for exporting data for AGO or Survey123 website after it is collected. It is coincidental that after you made this change that you encountered issues with the app.

I notice you are using an older version 2.7 of Connect, which is different to the app version you are using. We highly recommend updating to latest version of Connect and App, or at a minimum ensuring you are using the same version for both. We recently released version 3.0 of Connect and App, which are available to download from the Survey123 website and app stores. I would be interested to know that if you install Connect 3.0 and re-publish your survey with updated choice lists and media csv files, if you then see the updated value when re-download the survey to the app on same devices.

Out of interest, are you using cascading selects and external choices via external_choices tab in your xlsx file, or are you using pulldata() to reference the csv in media folder?

Phil.

0 Kudos
JohnSmith40
New Contributor III

Hello Phil,

I downloaded Connect Version 3.0. I deleted the local folder for this survey and then redownloaded it from the cloud. I created a new CSV cloning the previous one. All of this resulted in the same outcome - when I publish and download the survey on a mobile device, it does not show the latest updates to the CSV / XLSX.

I am using pulldata() to reference a CSV in the media folder. This CSV has all of the project names and project information and mirrors the project name options in the "choices" tab for the select_one type within the XLSX form. The survey preview in the Connect application shows the latest updates to the CSV / XLSX but for some reason these changes are not published to mobile devices. Is there some type of setting in Connect or in the feature layer itself accessed on AGOL that when changed could explain this type of behavior?

Thank you again for your help.

0 Kudos
Philip-Wilson
Esri Frequent Contributor

Hi John,

Are you able to send me a copy of your xlsx file and the csv files in the media folder so I can take a closer look to try and replicate. If unable to share publicly, can you send them to me via email. I will send you a private message with my details.

Phil.

0 Kudos