Survey123 Inbox refresh request times out CODE 504

07-14-2021 09:41 PM
New Contributor II
I get the following message when downloading/refreshing surveys to the Inbox. My feature service for the survey has transect inspections consisting of 6800 records and related table vegetation data is 70,000. This is already filtered. It times out fetching the related records by the looks. I have increased the max record count for both the transect inspection table and the related record table accordingly.
When I take a subset, of 500 transects and 4000 related table vegetation data it works fine downloading to the inbox.
I am using Survey123  Version 3.12 .277 and the same thing happens on ipad, iphone and windows app.

0 Kudos
2 Replies
Esri Regular Contributor

Hello @SarahPC

I would suggest reaching out to Esri Technical Support and they will be able to help troubleshoot the issue to narrow down what's happening. 

Survey123 sends a queryRelatedRecords REST request when accessing the related records in the inbox. I'm thinking the error is coming from the server side. Sending the request outside of Survey123 would be able to confirm if that's the case. 

Has this issue started recently? Has the inbox query worked in the past and this behavior came up recently, or has it never worked? 

Thank you, 



0 Kudos
New Contributor II

Thanks @ZacharySutherby , I have only just found the issue so I am not sure how long it has been going as I havent had the requirement to refresh the Inbox like this before.

0 Kudos